Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My keyboard is behaving weirdly. I suppose my keyboard layout which was US by default has been changed to another format. Also a very strange sound is coming from my laptop every time when its booting. Please help me.

share|improve this question
Is there a small keyboard icon on the right side of the top panel? If so, what do you see if you click on it? Please edit the original question to answer. – user68186 Aug 24 '12 at 18:39

you can change your keyboard layout to your's desired one.type as keyboard in your unity dash or open system settings , there you will find keyboard layout option .click it to open and in that window ,click at layouts and there you can set your layout .for more information you can have a look at the image .enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.