Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install Guest Additions in a virtual Windows 7 running inside Ubuntu. The VirtualBox instructions are:

In the "Devices" menu in the virtual machine's menu bar, VirtualBox has a handy menu item named "Install guest additions", which mounts the Guest Additions ISO file inside your virtual machine. A Windows guest should then automatically start the Guest Additions installer, which installs the Guest Additions into your Windows guest.

How do I get to the "Devices" menu in the virtual machine's menu bar?

virtual Win 7

virtual box manager

share|improve this question
    
It's the third menu, can't you see the menus? –  Javier Rivera Aug 24 '12 at 10:53
    
A virtual Windows 7 looks like a real Windows 7. I've never seen a Devices menu in Window 7. –  broiyan Aug 24 '12 at 10:54
    
Are you running in seamless mode? –  Javier Rivera Aug 24 '12 at 10:57
    
I have a Windows 7 window and some Virtual Box indicators along the bottom of the window. I also have a Virtual Box Manager. I don't know what seamless mode is but my cursor works inside and outside the virtual machine window. –  broiyan Aug 24 '12 at 10:59
2  
Having 517 rep, I'm sure that you know how unity menu works. Just in case, hover over the top bar to see the app menu, while VirtualBox window is selected. If there is no VBox menu there, you have found a bug. –  Javier Rivera Aug 24 '12 at 11:09
show 1 more comment

4 Answers

up vote 2 down vote accepted

Right There, Third Menu option.Click it a drop down menu will appear, the last Option is to Install Guest Additions.

  • When you boot into Windows Press Host+D (Host is usually the right Control key). That will mount the Vbox Guest Additions ISO into Windows and the autorun prompt will appear.

enter image description here

share|improve this answer
    
My virtual machine just has a Windows task bar at the bottom and the usual contents in the Windows Start menu. –  broiyan Aug 24 '12 at 10:56
    
I don't see that menu bar. Right clicking doesn't offer any way to enable a menu bar either. Stretching the Ubuntu window that surrounds the virtual Win7 does not reveal anything, just whitespace borders around Windows blue wallpaper. –  broiyan Aug 24 '12 at 11:07
1  
If you're using Unity which i suppose you're since you don't have the menubar hover the mouse over the top panel to reveal it. –  Uri Herrera Aug 24 '12 at 11:12
    
I'm sorry. I'm running Lucid and for the last hour I've tried to get out of seamless mode or get into a mode where the Windows guest is running inside as shown in the illustration above. I've pressed Host+D, screamed, beat my chest, etc. Nothing will get me what I see illustrated here. Would you answer the second comment above (I don't see that menu bar)? –  Russ Bateman Feb 16 '13 at 17:43
add comment

There are a couple of ways to run a VirtualBox VM in Ubuntu, the most used is windowed mode, when using it the Virtual Machine is inside a window, it looks like this:

enter image description here

The menu should be in the same place that other windows. Bellow the title, or if you are using unity, it will appear when you hover over the bar that is located at the top of the screen.

I believe that you could be running it on seamless mode. In this mode the virtual machine will try to mend with the Ubuntu desktop and it doesn't has its own window.

If this is your situation you have two options:

  1. Move the mouse to the middle bottom of the windows taskbar, try to put it as low as possible. Let it hold there for a second or two. A new menu bar should appear.
  2. Hit CTRL+L while you have windows selected, this should change it to above mode (in a window), you should then be able to access the menu in the normal way.
share|improve this answer
    
The OP's screenshot shows the windows background so it's not seamless mode. I use it occasionally and the windows menu bar gets displayed at the bottom of the screen. –  StarNamer Aug 24 '12 at 12:39
    
Yes I know, there was no screenshot when I wrote the answer. I left it there, it could be useful to someone else. –  Javier Rivera Aug 24 '12 at 14:11
add comment

I had the same issue....beating my head against the wall. Once the Win7 device is and you log in, go to My Computer and open the CDROM...the iso will be there. Run the installer and reboot. You'll be good to go.

share|improve this answer
add comment

You have Scale Mode enabled. Disable it (CTRL C) and you will see the Devices Menu for your VM. You can then install the Guest Additions

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.