Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My computer shows windows in a somewhat tired manner :) It is a desktop with an onboard Intel card but with a discrete Nvidia card in a PCI slot. The Intel card is disabled in BIOS.

Somebody suggested to run glxgears and I got this kind of an error ...

$ glxgears
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't get an RGB, Double-buffered visual

Other information that might help are as follows

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.1 LTS
Release:    12.04
Codename:   precise

$ sudo lshw -c video
       description: Display controller
       product: 82G33/G31 Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 10
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:42 memory:fdf00000-fdf7ffff ioport:f400(size=8) memory:a0000000-afffffff memory:fdc00000-fdcfffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: GT218 [GeForce 8400 GS]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:fb000000-fbffffff memory:b0000000-bfffffff memory:ce000000-cfffffff ioport:ef00(size=128) memory:c0000000-c007ffff

$ jockey-text -l
xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)

$ lspci 
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:02.0 Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
05:00.0 PCI bridge: PLX Technology, Inc. PEX8112 x1 Lane PCI Express-to-PCI Bridge (rev aa)
06:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
06:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

I just want to know if its normal that glxgears should fail or there is some configuration issue with my computer ..

Tried this nothing happened ..

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

And then tried this and this happened :)

$ sudo jockey-text -e xorg:nvidia_current

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log
$ tail -20 /var/log/jockey.log
2012-08-24 19:09:13,652 DEBUG: NVidia(nvidia_current).enabled(): target_alt /usr/lib/nvidia-current/ current_alt /usr/lib/nvidia-current/ other target alt /usr/lib/nvidia-current/ other current alt /usr/lib/nvidia-current/
2012-08-24 19:09:13,652 DEBUG: KMH enabled: False
2012-08-24 19:09:14,308 WARNING: modinfo for module nvidia_current failed: ERROR: modinfo: could not find module nvidia_current

2012-08-24 19:09:14,308 ERROR: XorgDriverHandler.enable(): package or module not installed, aborting
2012-08-24 19:09:46,485 DEBUG: NVidia(nvidia_current).enabled(): target_alt /usr/lib/nvidia-current/ current_alt /usr/lib/nvidia-current/ other target alt /usr/lib/nvidia-current/ other current alt /usr/lib/nvidia-current/
2012-08-24 19:09:46,485 DEBUG: KMH enabled: False
2012-08-24 19:09:46,513 DEBUG: NVidia(nvidia_current).enabled(): target_alt /usr/lib/nvidia-current/ current_alt /usr/lib/nvidia-current/ other target alt /usr/lib/nvidia-current/ other current alt /usr/lib/nvidia-current/
2012-08-24 19:09:46,513 DEBUG: KMH enabled: False
share|improve this question
Have you tried running glxspheres? In my research, it is shown to be a better indicator of Nvidia graphic card capabilities. – charlie May 23 '13 at 6:35

No, it's not normal that glxgears fail. It's failing because you don't have the GLX set up on your system. You need to install the drivers for your card to have full 3D support.

As shown by jockey, you are not using the proprietary drivers for your nvidia card, so i suggest the following:

  1. Activate the proprietary drivers:

    sudo jockey-text -e xorg:nvidia_current
  2. See if the problem remains

To remove NVIDIA proprietary driver:

  1. sudo apt-get purge nvidia-current

  2. sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

  3. sudo apt-get --reinstall install libgl1-mesa-glx

  4. reboot

Instalation Aditional drivers

sudo apt-get install nvidia-current


Instalation NVDIA drivers

Go to choose the linux driver for your geforce card

Go to the place you have your file and run:

Choose one of this methods, and see which one worsks for you, although adiitional drivers is recommended. sudo sh

Follow instructions and reboot

share|improve this answer
there is some problem. How do i post the output here if its a bit longer. Should I answer the question or something else, dont know how it goes – sheri Aug 24 '12 at 10:11
@sheri Edit your question to reflect it and leave a comment here referencing the edit. – Oli Aug 24 '12 at 10:18
@Oli yup got that. This method of updating the question is pretty awesome. Keeps the content clean and discussion focused. I get an error – sheri Aug 24 '12 at 10:24
@LnxSlck I have posted the error after running the command you suggested. Any insight? – sheri Aug 25 '12 at 6:08
My advise would be fully remove any NVIDIA drivers you have, reboot, and install the NVIDIA drivers for your card via apt-get. If that doesn't work, remove them again, go to and install theirs drivers, that has got to work! Do you need help on any of these steps? – LnxSlck Aug 25 '12 at 10:59

Remove any NVIDIA drivers you have and instal Bumblebee or run Xubuntu

share|improve this answer
Is it an Optimus computer? The Integrated Graphics card looks quite old.… – David Aug 25 '12 at 17:49
Bumblebee aims to provide support for NVIDIA Optimus laptops for GNU/Linux distributions. This does not seem to be the case here – LnxSlck Aug 25 '12 at 18:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.