Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 12.04 LTS on my laptop and I'm having some problems with the screen.

Whenever I change from a window to another, the screen seems like it had stripes; but after two or three seconds, it works in a normal way.

The same thing happens when I'm writing on the keyboard happens, so I can't see if I'm writing right or not.

I've tried to install the additional controllers that appear on the system configuration menu, but when I click on the activate, after a minute or so appears a message saying:

We are sorry, the installation of the driver failed:
Check  the log to see the details:/var/log/jockey.log.

There are two additional controllers:

  1. FGLRX propietary graphics driver for ATI/AMD (post-release updates)
  2. FGLRX propietary graphics driver for ATI/AMD

My computer is a Toshiba Satellite L850-150.

I hope you can help me.

share|improve this question

1 Answer 1

Install the 2nd driver, as I believe the post release updates aren't supported anymore. If that doesn't work, manually install them:

sudo apt-get remove --purge fglrx fglrx-amdcccle

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-upadtes

Restart. Then:

sudo apt-get update

sudo apt-get install fglrx* fglrx-amdcccle fglrx-dev

sudo aticonfig --initial

Restart, and the drivers should be installed.

Double check:

fglrxinfo

...And if it outputs something like:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6300M Series
OpenGL version string: 4.2.11733 Compatibility Profile Context
share|improve this answer
    
thank you! this solved the problem, but just when I'm using batery, when I remove it, and plug only the charger, it doesn,t work. What should I do? –  David Aug 25 '12 at 10:45
    
Sorry, I have no idea what could be causing that. You can always download the latest drivers from AMDs homepage, though I haven't tried this before, remove the drivers you installed before through the commands in my previous answer, then run sudo sh [driver].run replacing [driver] with the name of the driver. –  Marco Scannadinari Aug 26 '12 at 11:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.