Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I use Xubuntu 12.04.1 LTS (xfce) with Thunar file manager.

enter image description here

I ran this command:

rm ~/.local/share/applications/wine-extension-jpe.desktop

And one Wine context menu item has gone.

How do I remove the other one?

share|improve this question

marked as duplicate by cipricus, Eric Carvalho, Zacharee1, Pilot6, David Foerster Feb 6 at 2:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

I see from your screenshot that you have right clicked an image file (because of the options presented in the context menu), and presumably it is a jpeg or jpg file, as you say you have removed wine-extension-jpe-desktop, and that has prevented one of the wine 'open in internet explorer' options from appearing when a jpeg is right-clicked. The other file that you want to remove is wine-extension-jfif.desktop, and then no wine options will appear when you right click a jpeg or a jpg.

If you take a look at the w3 standards page, you can see that jpeg jfif is known as the JPEG File Interchange Format; it is known as a progressive jpeg that is heavily compressed. Much more information and technical specifications is available in the official jfif pdf.

If you want other image extensions not to appear in the context menu as well, remove also wine-extension-gif.desktop and wine-extension-png.desktop from ~/.local/share/applications. You can easily reassociate a wine program as an option with which to open these filetypes through the 'open with' dialogue or set as default via, for example, mimeopen -d mypicture.jpeg. Although very few users probably use wine programs to view images or edit them when excellent native Linux based programs are available.

share|improve this answer

Look in ~/.local/share/applications/, possibly delete all files that seem related to the applications involved, especially mimeinfo.cache.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.