Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 64bit using ivy bridge integrated graphics (intel HD 4000).

The motherboard has a VGA and DVI output, both of which I've connected to monitors.

Upon boot, both monitors show the same image (they are mirrored). In Display settings, I can only see one monitor listed (labeled 'Laptop'). Pressing "Detect Displays" does not appear to do anything.

I've installed sudo apt-get install xserver-xorg-video-intel with no error messages and have updated to the September 9 release.

Possibly relevant info:

$ xrandr --query
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024       0.0* 
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0  

$ lshw -C
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: Ivy Bridge Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller cap_list
       configuration: latency=0
       resources: memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)


$ lspci
...
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
...
share|improve this question
    
Please post the content of /etc/X11/xorg.conf –  MestreLion Sep 20 '12 at 2:30
    
@MestreLion The file doesn't exist. Should I create something there? –  bdares Sep 20 '12 at 2:47
    
Not necessarily. The xorg.conf is not required for normal usage, but if it exists, it allows you to tweak display settings, so maybe crafting one may solve your issue –  MestreLion Sep 20 '12 at 11:10
    
Take a look here: x.org/wiki –  MestreLion Sep 20 '12 at 11:25
    
Also, this might a long shot, but... have you tried installing mesa-util package? (and the related ones too?). Worth a shot –  MestreLion Sep 20 '12 at 11:26
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.