Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hugin (panorama stitcher): Any help?

===> hugin
/usr/share/hugin/data/plugins/woa.py
   CAT:Control Points
   NAM:Warped Overlap Analysis
   fails @api-max
/usr/share/hugin/data/plugins/top_five.py
   CAT:Control Points
   NAM:keep 5 CPs per image pair
   fails @api-max
/usr/share/hugin/data/plugins/crop_cp.py
   CAT:Control Points
   NAM:Crop Control Points
   fails @api-max
/usr/share/hugin/data/plugins/shooting_pattern.py
   CAT:initial distribution
   NAM:6-1-1 Shooting Pattern
   fails @api-max
The program 'hugin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 1148 error_code 1 request_code 154 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Linux e520 3.2.0-30-generic-pae #47-Ubuntu SMP Wed Aug 15 18:52:06 UTC 2012 i686 i686 i386 GNU/Linux
guettli@e520:~


Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-30-generic-pae i686)
share|improve this question

closed as off-topic by Braiam, guntbert, mikewhatever, minerz029, Radu Rădeanu Jan 12 at 0:03

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, guntbert, mikewhatever, minerz029, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Aug 23 '12 at 19:57

2 Answers 2

up vote 1 down vote accepted

If you have an ATI card, you can try to deinstall the fglrx package and install the fglrx-update package.

share|improve this answer
    
Thank you for this hint. The package fglrx-update was already installed and I removed it. Now I can run hugin and AngryBirds (via wine) again. –  guettli Sep 1 '12 at 10:07
1  
Related ticket on launchpad: bugs.launchpad.net/hugin/+bug/993923 –  guettli Sep 1 '12 at 10:11

With or without fglrx-update I had several errors. Not only hugin, other apps, too. I installed Ubuntu 13.04, and the problems are gone. The root of the problem is still unknown, but I don't care any more.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.