Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got myself an Asus k53br. and indeed all fn + random button functions work except my multimedia buttons on the arrow keys. is there any chance I can get them to work?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If the kernel recognises your keys you should be able to set them. I had a similar problem (with a different laptop) and was lucky and managed to set them The information you want is probably here at the Ubuntu help pages, but this is a run-through of what I did thanks in part to that help page.

Before pressing the keys open up gnome-system-log or run

tail -f /var/log/kern.log

When you press the keys, the kernel should give an indication if they are recognised and will report something like the keys are not set and so give you a scancode:

Use 'setkeycodes e074 <keycode>' to make it known

Now check your free keycodes that you can associate it with by entering

sudo dumpkeys | grep ^keycode

Usually it's best to use a high number so as not to mess up any existing keycodes. To temporarily set the key use the value the kernel gave you and a high keycode value such as 131:

sudo setkeycodes e074 131 

Now, if you are lucky a keysym will have automatically been assigned and you will now be able to use the button (for this session) and it will be available to set in your keyboard shortcuts program.

To make the setting permanent and so it sets it every time you reboot, add the entry to /etc/rc.local before the exit 0. Use sudo nano -w /etc/rc.local and add, for example,

setkeycodes e074 131

Replace my examples with your own settings at all stages in the above process.

If the keysym has not been set, you need to go through the process detailed at the Ubuntu help page. It is quite a long process so I can't repeat it all here, but the section begins at 3. Assigning X keysyms

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.