Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using Kubuntu since 9.04 but I've decided to switch to Ubuntu (read: GNOME) now. I've installed ubuntu-desktop a while ago, I think the system was in 9.10 then. I'm now at 10.10, all via upgrades (never a reinstall).

Presumably because of this, I'm missing a few things in my GNOME when compared to a clean install of Ubuntu 10.10:

  • Notifications (msn contact online, battery low, etc.) look out of style. They look like text clouds instead of shiny Ambiance boxes. This is how they look:

Ugly Notification

  • I'm missing my name and shutdown options in the top right of the panel

How can I restore these?

share|improve this question
up vote 1 down vote accepted

If the session applet is installed,it may be a matter of simply right clicking the panel and choosing add to panel. The Applet you need for your name is "indicate applet session"

share|improve this answer
And somehow the notifications were fixed automatically after a reboot – Bart van Heukelom Dec 18 '10 at 17:46

Such settings are (most likely) controlled by config files in your home folder. .config/ has many, and there are many application-specific folders as well. Finding which of these match up with the specific issues you having can be done with google's help.

Once you know what the application is, and where the offending settings are, remove the application, remove the settings file/folder (after backing up), and reinstall the application.

share|improve this answer

You probably need to install notify-osd Install notify-osd (To fix the notifications) and indicator-applet Install indicator-applet and
indicator-applet-session Install indicator-applet-session to fix your second problem.

share|improve this answer
According to the software center, I already have them – Bart van Heukelom Dec 17 '10 at 21:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.