Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Kubuntu 12.04 and QtCurve widget style which does not support GTK3:

enter image description here

How can apply a GNOME theme for GTK3 apps?

I found an advice here: installed gnome-themes-standard and gnome-themes-extras packages, created file ~/.config/gtk-3.0/settings.ini:

[Settings]
gtk-theme-name = Adwaita
gtk-fallback-icon-theme = gnome

But this didn't help.

share|improve this question
    
Do you see any other options in GTK+ Appearance – KDE Control Module? –  Oleh Prypin Aug 23 '12 at 8:41

1 Answer 1

up vote 3 down vote accepted

There's a great tool that let's you easily configure GTK2 and GTK3 themes on KDE:

GTK2 + GTK3 Configuration under KDE

.deb for i386

https://launchpad.net/~cyberspace/+archive/archive/+files/kde-gtk-config_201204221133~precise1_i386.deb

.deb for AMD64

https://launchpad.net/~cyberspace/+archive/archive/+files/kde-gtk-config_201204221133~precise1_amd64.deb

Go to the place where you downloaded your file and in a console type:

sudo dpkg -i package_name.deb

Where package name is the name of the package you downloaded

If it complains about a ependeny kdebase-runtime needed, simply install it by:

sudo apt-get install kdebase-runtime

On KDE System Settings - Applications Appearance you now have more 2 menus on the left tab, where you can choose GTK2 or GTK3 themes

enter image description here

Source: https://projects.kde.org/projects/playground/base/kde-gtk-config

share|improve this answer
    
I installed the package, the GTK2 theme works ok, but the GTK3 theme is not changing, whatever theme for it i select: imgur.com/zsEro Even oxygen-gtk –  warvariuc Aug 23 '12 at 11:25
    
You may also find usefull installing these addons :sudo apt-get install gtk2-engines-oxygen gtk3-engines-oxygen kde-config-gtk oxygen-molecule –  LnxSlck Aug 23 '12 at 13:08
    
I have these installed - still the same –  warvariuc Aug 23 '12 at 13:25
    
Try removing that settings.ini file you have altered and then setting a new GTK3 theme –  LnxSlck Aug 23 '12 at 14:30
    
sorry, doesn't help –  warvariuc Aug 23 '12 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.