Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have several problems with my ubuntu 12.04, which I think interrelated. My first problem is that recently my kernel got updated to 3.2.0-29 (I'm not sure whether it was just generic or generic-pae). Since then my virtual box was not loading displaying an error code Kernel driver not installed (rc=-1908). So, I tried many work arounds, suggested in several threads with no use. I tried to remove, reinstall virtualbox from different sources, no use. When I looked at my synaptic and found that old kernels to be present (3.2.0-27 & 26). In the event of removing them, thinking that they may be causing problem with virtualbox, I accidentally removed my all the kernels, so I couldnot boot. Hence I followed method adviced in this thread How to restore a system after accidentally removing all kernels? (detail method). I didn't know which kernel to install. As my pc has more than 3gb ram, i used generic-pae.

So now when I boot my computer everytime, I'm prompted to grub2 loader menu asking which kernel to use. But I have only one kernel. It also asks whether I should repair kernel (but repair doesnot work, it displays same menu again). I updated grub, but no use. I want to your help on this. I want my laptop to boot & load automatically.

Second is if I run virtual box it displays same error code, described earlier. If I run sudo modprobe vboxdrv the problem gets solved for this boot. But when I reboot, same problem with virtual box.

I greatly appreciate your assistance on this.

Thanks in advance

share|improve this question
1  
Welcome to Ask Ubuntu! Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /etc/default/grub, /boot/grub/grub.cfg –  izx Aug 23 '12 at 6:37
    
I am not able to post the uut put of /etc/default/grub, it is exceeding the character limit. What to do? –  kums Aug 23 '12 at 9:42
    
Sorry I didnt recognize your instructions! Here is the output of etc/default/grub: paste.ubuntu.com/1162405 & output of /boot/grub/grub.cfg is : paste.ubuntu.com/1162418 Hope this helps you to figure out problem with my computer –  kums Aug 23 '12 at 10:24
add comment

1 Answer

As for the Virtual Box, try the following.

sudo apt-get install --reinstall virtualbox-ose-dkms

Read carefully what the command returned. If it says anything along the lines that it cannot compile the driver, you will have to install the linux header files manually. First, find out what the kernel version is:

uname -r

It will show you something like that:

2.6.32-42-generic-pae

Then, install the headers and reinstall the dkms again:

sudo apt-get install linux-headers-2.6.32-42-generic-pae
sudo apt-get install --reinstall virtualbox-ose-dkms

As for your GRUB trouble, try to reinstall grub:

update-grub

What is the output of that command?

share|improve this answer
    
output of step 1 was Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded. Need to get 0 B/22.2 kB of archives. After this operation, 0 B of additional disk space will be used. (Reading database ... 215724 files and directories currently installed.) Preparing to replace virtualbox-ose-dkms 4.1.12-dfsg-2ubuntu0.1 (using .../virtualbox-ose-dkms_4.1.12-dfsg-2ubuntu0.1_all.deb) ... Unpacking replacement virtualbox-ose-dkms ... Setting up virtualbox-ose-dkms (4.1.12-dfsg-2ubuntu0.1) ... –  kums Aug 23 '12 at 9:51
    
updated grub output of command was: Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.0-29-generic-pae Found initrd image: /boot/initrd.img-3.2.0-29-generic-pae Found memtest86+ image: /boot/memtest86+.bin done But when I rebooted all problems remained same! Please help –  kums Aug 23 '12 at 9:58
    
Can anybody help on this???? –  kums Aug 24 '12 at 10:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.