Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running 12.04. I can manually suspend the system and wake it up again, but I can't get it to suspend on inactivity automatically.

I have it set to "Suspend when inactive for" 10 minutes in systems settings > power. It just blanks the screen, but does not suspend.

Info as requested. Left system untouched at 18:30 with suspend set to 10 minutes.

kern.log and dmesg had nothing new in them.

sys.log had these extra lines

Aug 23 18:34:26 Ubuntu-desktop AptDaemon: INFO: Quitting due to inactivity
Aug 23 18:34:26 Ubuntu-desktop AptDaemon: INFO: Quitting was requested
Aug 23 18:39:01 Ubuntu-desktop CRON[3228]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete)
share|improve this question
    
After making sure your system attempts to suspend/blank screen at least once, without rebooting, please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, /var/log/syslog, command(s): dmesg –  izx Aug 23 '12 at 6:49
    
Very little extra info was posted to the log files, but I have edited my question with what was added as the system went into blank screen with no-suspend. –  Jazz Aug 23 '12 at 9:08
add comment

2 Answers 2

up vote 1 down vote accepted

Well, I finally managed to get it to suspend fully on inactivity.

In addition to System Settings > Power set to turn off after 10 minutes, I had to ALSO set System Settings > Brightness and Lock to turn off the screen after 10 minutes.

Surely if these 2 settings are dependent on each other they should be together in one section of System Settings? The way they interact seems wrong, and the Systems Settings > Power section doesn't hint or warn that it can't be set independently.

share|improve this answer
    
I was having similar problems with my system not sleeping. I took your advice here, and it solved my problems. The thing is, now it seems to work perfectly fine if I revert all my settings! Perhaps the toggle was all that was needed. FWIW, I can have the 2 settings different now. Via dconf-editor, I also toggled org.gnome.desktop.lockdown disable-lock-screen (originally true) and could leave both org.gnome.desktop.screensaver lock-enabled and ubuntu-lock-on-suspend as either true or false. –  Sparhawk Sep 24 '12 at 23:25
    
Also, note that the timing is not correct. e.g. (via dconf) I can set org.gnome.settings-daemon.plugins.power sleep-display-ac and sleep-inactive-ac-timeout to 5 and 5, and they'll work at 30 and 70. Similarly, 60 and 60 results in the computer suspending around 90 seconds. –  Sparhawk Sep 24 '12 at 23:27
    
I just filed a bug for this second issue. –  Sparhawk Sep 24 '12 at 23:55
add comment

Had same issue on 12.04, fixed by setting org.gnome.settings-daemon.plugins.power sleep-display-battery to a value lower than the value of sleep-inactive-battery-timeout.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.