Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Windows Vista and 12.04 on my Dell D630 laptop. I'm using Huawei MT882 modem.

I have installed Ubuntu two days ago using WUBI.

I have tried with USB or ADSL cable but on Ubuntu, Internet connection won't work. On Windows however, it works perfectly (both USB and ADSL cable).

Is there any way to fix this problem?

Output of ifconfig:

eth0  Link encap:Ethernet  HWaddr 00:1c:23:0c:c5:cc  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:17 

eth1  Link encap:Ethernet  HWaddr 00:1b:9e:bc:0d:da  
      inet6 addr: fe80::21b:9eff:febc:dda/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:2 errors:0 dropped:0 overruns:0 frame:0
      TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:557 (557.0 B)  TX bytes:5862 (5.8 KB)

lo    Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:704 errors:0 dropped:0 overruns:0 frame:0
      TX packets:704 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:56736 (56.7 KB)  TX bytes:56736 (56.7 KB)

And output of nmcli dev:

eth1       802-3-ethernet    connecting (getting IP configuration)
eth0       802-3-ethernet    unavailable  
wlan0      802-11-wireless   unavailable
share|improve this question
    
Is that a router or a modem? Could you post the outputs of ifconfig and nmcli dev? –  jeremija Aug 22 '12 at 20:08
    
It is a modem, Huawei MT882 –  Nikola Ninkovic Aug 22 '12 at 20:23
add comment

2 Answers

You may need to manually create a DSL connection, start nm-connection-editor, go to the DSL tab and click Add:

network connections dialog

enter image description here

Then enter your username, password and service name you got from your Internet Provider. I think that the service name is optional. Go to the Wired tab and choose the Device MAC address from the network card you connected the modem to. From what I see in your output of nmcli dev, it should probably be 00:1B:9E:bC:0D:DA (eth1).

Then go to IPv4 settings and make sure that the Method is Automatic (PPPoE). Check Connect automatically, click Save and see if it connects.

share|improve this answer
add comment

You might like to try this hopefully it'll work for you as it did for me;

In edit connectios make sure the Connection Name: is Auto(eth0)- NOT Wired Connection,-In the IP v4 Settings set Method: to Automatic(DHCP),- Tick both boxes for 1.Require IP4 addressing for this connection to complete and 2. Available to all users

In IP v 6 Settings set Method: to Ignore, and tick the box for Available to all users

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.