Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This might seem so similar to many other posts regarding Nvidia Optimus Graphic Cards troubles and the pain it inflicts on its Linux users but my question is actually simply how to go back to my last graphical settings rather than how to make my nVidia VGA work.

After facing a complete misery by trying out Bumblebee on my 12.04 machine and having to change my entire OS, I again dared to try it out this time with version 3.0.

Everything was working great, I Enabled my nVidia VGA from BIOS and installed Bumblebee-nvidia. Firstly following the official instructions and then not finding it explanatory enough followed this page guides.

In short not surprisingly it didn't work with errors like: Bumblebee service is not running and graphic module can't be found but it also left me with a glitchy graphic experience. (As an example hovering the mouse over menu items leaves a trace and highlighting texts specially in bash causes the highlights to overlap creating a mess)

So I reversed every single thing I had done to go back to where I started. Un-installing all the installed packages including bumblebee, nvidia drivers and anything else I had installed according to the guides and in the end disabled my nVidia again from the BIOS.

But the buggy, glitchy, laggy graphic is still with me. I even disabled the open source Intel driver, rebooted and still no success. I am out of ideas.

So my question, above if anyone knows a comprehensive elaborated guide on how to install bumblebee specifically on 12.04 for nVidia and if someone can guess what I have done wrong depriving myself from having a dual VGA experience is:

How to revert my graphic settings to its initial state before the adventure began? Isn't there a sort of System Restore command just like in Windows to go back in time regardless of what you have done?

PS: It could be worthy to mention that before I didn't have any proprietary drivers installed according to the ADDITIONAL DRIVERS control panel but now I have all sorts of open source items there like driver for Bluetooth, mac_hid, REalTec sound card, LPC interface, Intel graphics (which I tried disabling but no change), Intel temperature monitor, HDA driver, USB, etc. It's weird how I didn't need any of these and everything was working perfectly but now all of them showed up there. It would be nice if someone could explain this as well

I just can't afford reinstalling Ubuntu again. Please Help.

This is the content of Xorg.0.log:

http://dl.dropbox.com/u/21796054/Xorg.0.log

And this is the status of the dpkg:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                       Version                                    Description
+++-==========================================-==========================================-====================================================================================================
ii  libgl1-mesa-glx                            8.1~git20120821.1cb07bd3-0ubuntu0sarvatt~p free implementation of the OpenGL API -- GLX runtime
un  nvidia-current                             <none>                                     (no description available)
/usr/lib/xorg:
total 112
drwxr-xr-x   3 root root  4096 Aug 22 15:11 .
drwxr-xr-x 288 root root 69632 Aug 23 13:53 ..
drwxr-xr-x   6 root root  4096 Aug 23 14:54 modules
-rw-r--r--   1 root root 31246 Jul  9 20:24 protocol.txt

/usr/lib/xorg/modules/:
total 1160
drwxr-xr-x 6 root root   4096 Aug 23 14:54 .
drwxr-xr-x 3 root root   4096 Aug 22 15:11 ..
drwxr-xr-x 2 root root   4096 Aug 22 21:00 drivers
drwxr-xr-x 2 root root   4096 Aug 23 14:54 extensions
drwxr-xr-x 2 root root   4096 Aug 22 15:13 input
-rw-r--r-- 1 root root  96840 Jul  9 20:25 libexa.so
-rw-r--r-- 1 root root  18624 Jul  9 20:25 libfbdevhw.so
-rw-r--r-- 1 root root 142280 Jul  9 20:25 libfb.so
-rw-r--r-- 1 root root 146080 Jul  9 20:25 libint10.so
-rw-r--r-- 1 root root  35152 Jul  9 20:25 libshadowfb.so
-rw-r--r-- 1 root root  26784 Jul  9 20:25 libshadow.so
-rw-r--r-- 1 root root  26952 Jul  9 20:25 libvbe.so
-rw-r--r-- 1 root root  31736 Jul  9 20:25 libvgahw.so
-rw-r--r-- 1 root root 187304 Jul  9 20:25 libwfb.so
-rw-r--r-- 1 root root 437408 Jul  9 20:25 libxaa.so
drwxr-xr-x 2 root root   4096 Aug 23 14:54 multimedia
share|improve this question
    
Have you tried askubuntu.com/a/180791/6969? If you are not using the nvidia card, don't install the nvidia-current driver. –  Lekensteyn Aug 30 '12 at 19:48
    
@Lekensteyn : THANK YOU FOR REPLYING, yes I have tried almost all the related posts on askubuntu for that matter but non helped. I actually don't have any single file or folder related to neither bumblebee or nvidia residing on my computer as of now and besides that my Nvidia card is disabled from BIOS settings. I have also uninstalled and reinstalled my standard vga card driver on linux several times (lost my 3D environment but gained it back after reinstall) but I still have the issues I mentioned above. Im getting convinced that the only way is to reinstall my ubuntu which is a pain :( –  Saba Ahang Aug 31 '12 at 7:23
    
You should not need to reinstall. Can you add /var/log/Xorg.0.log and add the output of dpkg -l nvidia-current libgl1-mesa-glx; ls -la /usr/lib/xorg /usr/lib/xorg/*/ –  Lekensteyn Aug 31 '12 at 9:41
    
@Lekensteyn I added the information. Thanks –  Saba Ahang Aug 31 '12 at 12:15
add comment

1 Answer

up vote 1 down vote accepted

I see you have installed the "X Crack" PPA which contains packages that are in development that may be rather unstable. Try removing it and upgrade any remaining packages:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

Then reboot. In the future, if you need more recent nvidia drivers, use the ubuntu-x-swat/x-updates PPA.

share|improve this answer
    
God I wish I could analyze things like you...This fixed my graphical issues to a GREEEAAAATT degree,,,almost perfect but there are still some very subtle imperfections e.g. when I hover over unity lunchpad icons (at the left) the text sometimes does not appear! and I have to move the cursor away and back to see it...but I can live with it... –  Saba Ahang Aug 31 '12 at 13:46
    
Can you also explain the proprietary drivers dialog and all those new drivers that were not there before? –  Saba Ahang Aug 31 '12 at 13:51
    
I would also be very grateful if you show me a link to an updated elaborated instruction on how to install bumblebee so that I don't install the edgers package by mistake following the steps. –  Saba Ahang Aug 31 '12 at 13:56
    
1) I think that the text issues are an issue that occurs due to changes in your user configuration. Try creating a new user and log into it. If the same issues exist there, you know it for sure. 2) The Additional drivers screen could have been updated by the xorg-edgers PPA as well. 3) askubuntu.com/a/36936/6969 –  Lekensteyn Aug 31 '12 at 13:57
    
btw, how did you find out about the fact that I have the edgers package installed? I can't find anything similar to it in any of the information I provided!!! I really want to be able to have some clue about troubleshooting myself, please kindly give me a word on how to fish myself rather than fishing for me –  Saba Ahang Aug 31 '12 at 14:01
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.