Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can plug headphones into the headphone jack, run alsamixer and see that I've just got 00 instead of M meaning the headphone jack is not muted. But no sound comes out.

share|improve this question
    
Is there a red light coming out of the headphone jack? I remember having an issue with a Mac Mini where the light would stay red (meaning optical output) and you had to change it. –  reverendj1 Aug 22 '12 at 19:08
    
Does sound come out of the computer instead, or is there no sound at all? –  Steve Kroon Aug 23 '12 at 6:54
    
@reverendj1 Yes, there is a red light coming out of the jack, now that you mention it. How would I go about changing this? –  John Baber Aug 23 '12 at 12:51
    
@Steve Kroon The sound continues to come out of the computer as if I hadn't done anything. –  John Baber Aug 23 '12 at 12:52
    
Do the headphones show as an output if you click on the speaker at the top right of the screen and select "Sound Settings"? Can you change to the headphones using that? –  Steve Kroon Aug 29 '12 at 8:55
add comment

1 Answer

Try this command:

sudo sh -c "echo 'options snd-hda-intel model=mbp55' >> /etc/modprobe.d/alsa-base.conf"

from the Ubuntu Documentation

share|improve this answer
    
Before blindly doing that, I looked at the end of /etc/modprobe.d/alsa-base.conf and am reminded that I had to do something like this before to get sound working at all To follow your answer, should I comment out the other snd-hda-intel line? –  John Baber Aug 24 '12 at 13:32
    
Yes, I would comment out the previous one and add this new one. Also, what is the exact model of Mac you are using? –  reverendj1 Aug 24 '12 at 14:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.