Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've uninstalled Ubuntu One from my system (Ubuntu 12.04) but I still get the Ubuntu One right click menu item (share, get link, etc) and the folders I used to sync still show Ubuntu One's icons (synced, syncing, etc) These issues happening in Nautilus.

Is there any way to get rid of this integration?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Run the following commands:

sudo apt-get purge ubuntuone-client* python-ubuntuone-storage*

Also, delete all the related folders:

rm -rf ~/.local/share/ubuntuone ~/.cache/ubuntuone ~/.config/ubuntuone ~/Ubuntu\ One
share|improve this answer
    
I don't know why someone downvoted your answer. I'll try this method to see if this works. –  Gabriel Aug 22 '12 at 17:06
1  
This did the trick. Thanks! –  Gabriel Aug 22 '12 at 17:58
    
Glad it worked! :) –  green7 Aug 22 '12 at 19:12
    
I'm using Ubuntu 13.10 and the case is opposite here. I never uninstalled Ubuntu One But the "Ubuntu one" option is not appearing on right click. any Idea @green7 ? –  Pavak Paul Nov 20 '13 at 9:41
add comment

If you have not logged out and back in, the plug-in code is still loaded and running in Nautilus. Any application which uses plug-ins will have to be restarted after those plug-ins have been removed, before they will disappear from the interface. For Nautilus, the easiest way to do this is to simply log out, and then back in after a few seconds.

share|improve this answer
    
Nope, restarted the machine and the integration is still there. –  Gabriel Aug 22 '12 at 17:07
    
Then you have not actually uninstalled Ubuntu One yet. –  dobey Aug 23 '12 at 14:18
    
yes, I had uninstalled Ubuntu One at the time (I did it through the Software Center). Restarting the system did nothing. @green7's answer was what made the Nautilus integration go away. –  Gabriel Aug 23 '12 at 19:16
    
You probably only removed the control panel, and not all of Ubuntu One, which is several applications and libraries that integrate with the system. Restarting the system didn't work, because you only removed one piece of the Ubuntu One suite; the control panel. –  dobey Aug 24 '12 at 1:31
    
As I said, I removed the Ubuntu One entry in the Software Center, which should have been enough since it's what any regular user would do. It wasn't. To remove it completely I had to apply green7's answer which shouldn't have to be necessary. It should've gone away after uninstalling, it didn't. I shouldn't have had the need to use the terminal but I did. –  Gabriel Aug 24 '12 at 10:20
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.