Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 12.04 LTS on my Samsung 305U notebook. The thing is when I close de lid it does't resume from suspension, the same problem reported Here. I removed the proprietary video drivers from system settings and it fixed the problem but videos runs choppy.

I tried to install ATI Catalyst drivers as shown Here I couldn't do it the way it was explained because it was impossible to install ia32-libs. Then I tried the second most voted aswear:

cd /tmp && wget -O
chmod +x
sudo sh

This way I was able to install ATI Catalyst, presumably in it's 12.6 version, but when I rebooted I got a "Unsupported AMD Hardrive" watermark it lower-right side of the screen.

Does that mean ATI Catalyst aren't installed properly? Is there any way to fix it? All I need is the notebook to resume from suspension while having the video drivers properly installed.

share|improve this question
if you can't install ia32-libs i suspect you're on x86 not x64 and you should just keep going with the directions anyway – RobotHumans Aug 22 '12 at 15:37
aking1012: Valid point as the code in the directions are example for x64 and but it states that the user should download what is appropriate for their machine. On the basis of Pablo's feedback I will revisit the directions to ensure this is made clear. – stephenmyall Aug 22 '12 at 19:20
@Pablo Viollier: On the AMD website when you were defining your driver, in Step 4 did you select Linux x86 OR Linux x86_64. Im thinking you selected the latter when it should have been x86 – stephenmyall Aug 22 '12 at 19:26

install it from the application of ubuntu -> additional drivers, it worked for me

share|improve this answer
If I install the drivers from there, the notebook won't resume after suspension. – Pablo Viollier Aug 22 '12 at 17:26
I use the drivers installed that way, and use the program Jupiter and how it works in my notebook the suspension. – user84911 Aug 24 '12 at 0:17

I am suspecting you may have installed the x64 drivers instead of the x86

Please confirm your machine is not 64bit. Your best course of action in this case is to follow the instructions on the previous Q&A direction from the start, ignore references for 64 bit only and be sure to download the x86 driver. Please advise AU if you experience any further issues

share|improve this answer
It doesn't matter if I choose x86 or x86_64 it always redirects me to downloading "AMD Catalyst™ Proprietary Display Driver - Linux x86 & Linux x86_64" Maybe I should re-install Ubuntu 12.04 under the 64bits version? The sticker on the keyboard say "E2 Vision AMD" so I'm selecting the E2-1800 APU" choice when downloading the driver. Thanks for your time! – Pablo Viollier Aug 23 '12 at 1:42
I have the 32bit version of Ubuntu 12.04 installed. – Pablo Viollier Aug 23 '12 at 3:00

Hi I have the same laptop I use 64b its OK I used to run 11.10 and that was a nightmare as each time I ran upgrades it overwrote the Radeon driver. I learnt to re-install quickly but still a pain. I have now installed the 12.04 64b and it worked without Radeon drivers and screen times out without having to re-boot each time. But its still runs very hot (I suspect the high level video card is going constantly) and I would like to know how to deal with that as its a pity to brun the laptop out one day.

But my suggestion to you is try the latest 64b and it should now screen save etc without problems. If your still stuck let me know Thanks

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.