Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here is my problem, I would really appreciate some help!

Hungarian accented characters (áíúöüóúű) stopped working. I use ubuntu through VNC, and I was trying to install wine. The install process from ubuntu software center stopped at 66 percent (it poped up a question I did not notice), I shot it down. After that I cannot use my accented keys. Even when I copy-paste strings form Win in the ubuntu-VNC window, it leaves out the accented characters. From 'xxáűőúüóöxx' becomes 'xxxx' after paste. The web browser and the command line utilities displays these characters correctly, only the keys don't do anything.

I tried to remove and install various font-packages, thet were recently updated/removed, but the problem is, I don't know the root cause, so basicly I just try stuff blindly.

Here is the recent content of the /var/log/apt/history.log file:

Start-Date: 2012-08-22  09:43:19
Install: libopenal1 (1.12.854-0ubuntu1~lucid1), ttf-umefont (411-1), wine1.2
 (1.2.2-0ubuntu2~lucid1), icoutils (0.29.1-0ubuntu1~lucid),
ttf-mscorefonts-installer (3.2ubuntu0.1),
wine (1.2.2-0ubuntu2~lucid1), cabextract
(1.2-3+lenny1build0.10.04.1), ttf-symbol-replacement (1.2.2-0ubuntu2~lucid1),
wine1.2-gecko (1.0.0-0ubuntu4), libmpg123-0 (1.12.1-0ubuntu1),
winbind (3.4.7~dfsg-1ubuntu3.10), libaudio2 (1.9.2-3),
gnome-exe-thumbnailer (0.7-0ubuntu1~lucid1),ttf-droid (1.00~b112+dfsg+1-0ubuntu1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2012-08-22  12:59:02

Start-Date: 2012-08-22  12:59:42
Remove: wine (1.2.2-0ubuntu2~lucid1)
End-Date: 2012-08-22  12:59:46

Start-Date: 2012-08-22  13:00:05
Remove: wine1.2 (1.2.2-0ubuntu2~lucid1)
End-Date: 2012-08-22  13:00:12

Start-Date: 2012-08-22  13:00:22
Remove: gnome-exe-thumbnailer (0.7-0ubuntu1~lucid1)
End-Date: 2012-08-22  13:00:27

Start-Date: 2012-08-22  13:00:38
Remove: ttf-symbol-replacement (1.2.2-0ubuntu2~lucid1)
End-Date: 2012-08-22  13:00:41

Start-Date: 2012-08-22  13:00:48
Remove: wine1.2-gecko (1.0.0-0ubuntu4)
End-Date: 2012-08-22  13:00:49

Start-Date: 2012-08-22  13:02:26
Install: wine1.0 (1.0.1-0ubuntu13), ttf-mscorefonts-installer (3.2ubuntu0.1),
wine1.0-gecko (0.1.0-0ubuntu1)
End-Date: 2012-08-22  13:04:15


Start-Date: 2012-08-22  13:27:49
Install: wine1.2 (1.2.2-0ubuntu2~lucid1), wine (1.2.2-0ubuntu2~lucid1),
ttf-symbol-replacement (1.2.2-0ubuntu2~lucid1), wine1.2-gecko (1.0.0-0ubuntu4),
gnome-exe-thumbnailer (0.7-0ubuntu1~lucid1)
Remove: wine1.0 (1.0.1-0ubuntu13),
wine1.0-gecko (0.1.0-0ubuntu1)
End-Date: 2012-08-22  13:28:25

Start-Date: 2012-08-22  13:40:20
Remove: ttf-umefont (411-1)
End-Date: 2012-08-22  13:40:24

Start-Date: 2012-08-22  13:56:41
Remove: ttf-mscorefonts-installer (3.2ubuntu0.1)
End-Date: 2012-08-22  13:56:45

Start-Date: 2012-08-22  13:57:51
Remove: ttf-symbol-replacement (1.2.2-0ubuntu2~lucid1)
End-Date: 2012-08-22  13:57:54

Start-Date: 2012-08-22  13:58:20
Remove: ttf-droid (1.00~b112+dfsg+1-0ubuntu1)
End-Date: 2012-08-22  13:58:32

Start-Date: 2012-08-22  13:58:39
Remove: ttf-wqy-microhei (0.2.0-beta-1)
End-Date: 2012-08-22  13:58:42
share|improve this question
add comment

1 Answer

Have you tried removing ttf-mscorefonts-installer package? It installs microsoft fonts to /usr/share/fonts/truetype/msttcorefonts/, maybe you should check there and ensure the directory is empty?

share|improve this answer
    
This package wasn't installed, the /usr/share/fonts/truetype/msttcorefonts/ directory only contained a README file. After installing this package, the directory still contained only this README file, with the same content: License refused, please reinstall this package... to get prompted for the license again. –  Adamsan Aug 22 '12 at 13:31
    
I reinstalled it with: sudo apt-get install --reinstall ttf-mscorefonts-installer , the readme file is gone, and the dir is full with *.ttf files. However, my problem is still there. Strange thing is, on my gui, on the console, these characters are displayed perfect, only when it gets it as input... It's like it's filtering out. –  Adamsan Aug 22 '12 at 13:44
    
Are these characters filtered or their glyphs are not being shown? Try this: Copy the string xxáűőúüóöxx and paste it somewhere so it becomes xxxx, now select and copy the new xxxx and paste it in a command line, and see whether the result is xxáűőúüóöxx or xxxx –  Ali Alidoust Aug 22 '12 at 13:51
    
The result is 'xxxx' when I copy and paste back in windows. I poked around in the System/Settings/Keyboard/Keyboardmodel, and something changed, now I can type most of the letters, but instead of ő,ű it prints o with a tilde and u with a caret sign. And the issue with the disappearing characters when copy-paste is still there. –  Adamsan Aug 22 '12 at 14:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.