Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run an Ubuntu 12.04 server as a virtual machine on a VMWare ESXi 5 server.

I've configured VMWare to shut the quest machines down the sane way (with an ACPI (if I understand it righ) shutdown signal so that guest OSes would do it).

And this works with other VMs (running Windows 7 Professional and openSuSE) but doesn't work with the Ubuntu server - VMWare still offers just to power them off when I ask it to stop the guest.

Any ideas how to fix this?

share|improve this question
sudo apt-get install open-vm-tools

solved the problem.

Seems like installing VMware tools from VMware repositories as desctibed here could help as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.