Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Alienware Dell PC with Intel HD 4000 Graphics (Ivy Bridge) as verified by the output of lspci | grep VGA posted below.

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)

The PC only has HDMI and DVI display outputs and using the HDMI output I am only being offered abnormal resolutions. As you can see below it does not even list HDMI1 or DVI1 but just only a fallback.

$ export DISPLAY=:0.0 && xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1360 x 768, maximum 1360 x 768
default connected 1360x768+0+0 0mm x 0mm
   1360x768        0.0* 
   1024x768        0.0  
   800x600         0.0  
   640x480         0.0  

How can I fix this? Does it just need to be configured differently or will I need to use a newer kernel (as Intel Graphics drivers are included in the kernel)?

Follow up: kernel to latest

Step 1:

Go to: http://kernel.ubuntu.com/~kernel-ppa/mainline/
Go to last: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/

Download: 

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/linux-headers-3.6.0-030600rc3-generic_3.6.0-030600rc3.201208221735_amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/linux-headers-3.6.0-030600rc3_3.6.0-030600rc3.201208221735_all.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/linux-image-3.6.0-030600rc3-generic_3.6.0-030600rc3.201208221735_amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/linux-image-extra-3.6.0-030600rc3-generic_3.6.0-030600rc3.201208221735_amd64.deb

Step 2: sudo dpkg -i linux*.deb

Step 3: reboot which shows that i have Ubuntu 12.04 with latest

$ uname -a
Linux sun-Alienware-X51 3.6.0-030600rc3-generic #201208221735 SMP Wed Aug 22 21:36:32 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

But still same problem remain.

share|improve this question
    
What kind of graphics card do you have (HMDI and DVI are usually routed through the graphics chipset)? –  adempewolff Aug 22 '12 at 10:55
    
Also please add exactly what problems you are having with the HDMI/DVI output(s). Are they not working at all, working partially, being buggy, or what? The more specific you are the more likely you will get a helpful answer. –  adempewolff Aug 22 '12 at 10:58
    
and what's your graphics card? lspci | grep VGA should do the trick if you don't know. –  adempewolff Aug 22 '12 at 11:15
    
let us continue this discussion in chat –  adempewolff Aug 22 '12 at 11:27
    
@adempewolff: i think its solved: gist.github.com/3424755 –  YumYumYum Aug 22 '12 at 11:47

1 Answer 1

up vote 3 down vote accepted

I downgraded the kernel to Lucid (10.02) kernel. (2.6.32) while running Precise (12.04). That fixed the problem of DVI/HDMI. Very likely, the problem is in one of intel related kernel modules.

I also tried xorg Lucid, which did not fix, and the tip or xorg, and did not fix. So, it's kernel module related for sure.

You can add the Lucid to apt's source and downgrade the kernel to Lucid's 2.16 kernel. That should get you going.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.