Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am installing bumblebee on my laptop(Ubuntu 10.10),and there are some problems when I use this code to install it:

  sudo add-apt-repository ppa:bumblebee/stable
  sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
  sudo apt-get update
  sudo apt-get install bumblebee bumblebee-nvidia
  sudo usermod -a -G bumblebee roselectric
  sudo reboot

I got this message in terminal:

  The following packages have unmet dependencies:
  bumblebee-nvidia: Depends: nvidia-current (>= 260.19.12~) but 260.19.06-0ubuntu1 is  not going to be installed
  E: Broken packages

Then I used sudo apt-get install to install nvidia-current and bumblebee, and installation succeeded. However, when I

  sudo apt-get install bumblebee-nvidia

I got this message in terminal:

  The following packages have unmet dependencies:
  bumblebee-nvidia: Depends: nvidia-current (>= 260.19.12~) but 260.19.06-0ubuntu1 is   going to be installed
  E: Broken packages

Do anyone knows how to solve this problem?

Thanks in advance.

share|improve this question

closed as off-topic by guntbert, Rafał Cieślak, Mateo, Florian Diesch, psusi Oct 22 '13 at 2:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

up vote 4 down vote accepted

10.10 is End of Life.

You should upgrade to 11.10 or newer to get continued support, and updated drivers. (11.04 is almost EOL, it will be end of life when 12.10 is released in October of 2012.)

Also, the PPA that LnxSlck referenced (in his now-deleted answer to this question) does not publish Maverick packages. Also, PPAs cannot publish (new) Maverick or EOL-release packages (EOL being Jaunty, Maverick, and others), which is why there are no Maverick packages containing updated nvidia drivers in that PPA.

This answer is basically a copy of my answer to "Ubuntu 10.10 cannot get nVidia driver 260.19.12?", which is regarding the PPA which was referenced in another answer to this question. This answer is supported by current information regarding LaunchPad and EOL release support for PPAs. LaunchPad does not support EOL release packages in PPAs anymore, and new EOL-release packages cannot be uploaded to, or be built within, PPAs on Launchpad.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.