Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Mono from source (because in the future I will need to fix a bug in it).

PROBLEM: The compiled Mono does not behave properly.

Note: http://www.mono-project.com/Compiling_Mono_From_Git is not the whole answer. SparkleShare runs fine on Ubuntu's packaged Mono, but I get a TypeLoadException after following the instructions on that page, so some DLL settings or something need to be configured too (confirmed on IRC), but I can't find a complete documentation, that is why I ask here.


I also tried this:

  1. Install Ubuntu 2012.04 (Mono is not installed by default)
  2. sudo apt-get install curl git
  3. Compile+Install Mono 2.11 using this automatic script

I am testing with SparkleShare.
Installing the .deb package would retrieve Ubuntu's Mono package (which I don't want).
Building SparkleShare on the machine itself fails saying Package requirements (mono >= 2.8) were not met).
So I just ran
sudo make install` after having compiled on a machine.

When I run it (mono bin/SparkleShare.exe):

A type load exception has occurred. at SparkleShare.Program.Main (System.String[] args) [0x00000]

The exact same thing works fine if I use Ubuntu's Mono instead of the built-from-source Mono.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I ended up rebuilding the source package, using the instructions given in the question How do I rebuild a package to include debugging information?

As a bonus, I get debugging information :-)

Then I can modify the Mono source that has been downloaded in step 3, and re-run from step 3 to have my modified Mono.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.