Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently installed Ubuntu 12.04, replacing windows vista on my Inspiron and it wont connect to the internet by any means. It won't detect any wireless networks and when I try the ethernet cord, I can see "wired connection 1" in the network manager but the symbol on the panel is a wireless signal with 0 bars. Furthermore when I open firefox, it says there isn't a connection. What should I do?


(NOT AN ANSWER) Ok so I've entered the required information, and changed the router settings so that it uses a static IP. Still the Inspiron refuses to recognize the connection. When I pull up the network manager, the only connection I see is "Wired Connection 1" but it says it was last used one day ago even though I currently have it plugged in. It's like the computer doesn't even recognise the attached ethernet cord.

share|improve this question
    
Regarding wireless not working, check to see if you've enabled the wireless drivers in Jockey (Alt-F2 / jockey-gtk / Enter). AS for the wired, check and make sure that your router is working, doesn't have MAC address filtering or anything funky enabled. –  adempewolff Aug 22 '12 at 5:53
    
I'm not sure if i've got anything funky enabled on my router, it should be on the default settings. The router does work on my Dell Inspiron N5030. So I would think the problem lies within the Inspiron 1501. –  Jeff Aug 22 '12 at 6:00
    
Well if u are using wired connection, for sure you need to enter the network settings(IP address, subnet, gateway etc.) only exception being DHCP connection. –  Vinit Aug 22 '12 at 6:13
    
How would I go about finding this information? –  Jeff Aug 22 '12 at 6:18
    
You can find the information from your network provider. They give a unique IP address, Subnet, gateway etc. settings for each connection.It must have been saved in your vista, and you must have forgot to note it down before wiping vista. –  Vinit Aug 22 '12 at 6:22
add comment

2 Answers 2

well.. my inspiron 1501 has a broadcom card.. you probably have the same card..

Run these commands in terminal:

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

sudo apt-get install b43-fwcutter firmware-b43-installer

Then unplug ethernet and reboot

share|improve this answer
add comment

Well if u are using wired connection, for sure you need to enter the network settings(IP address, subnet, gateway etc.) only exception being DHCP connection.So all u need to to do is go to network manager, click on 'Wired connection 1' then to go IPv4 I am assuming you are having a IPv4 connection. Then Go to manual Screenshot of Network settings.I have network setting filled, you also check your appropriate network settings and fill them out. Once done everything should work like a charm.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.