Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have searched around the net for a solution to my problem. I gave myself an account user name for facebook so I could use the chat in Pidgin 2.10.3. However, no matter what I do, Pidgin refuses to enable the account and it gives me the same message: disabled Not Authorized

I used the tutorial on at this blog:

share|improve this question
Refer here Try logging in Facebook with username from Browser and do the same with pidgin , it might work. – atenz Aug 22 '12 at 4:58
"Not Authorized" means your pidgin is not allowed to connect to facebook. Find the "Allowed Applikations" or similar Settings in facebook and allow pidgin to connect with your facebook account. – mondjunge Aug 22 '12 at 7:37
As of May 2015, Facebook chat no longer works from Pidgin. See:…;. – RobinHood70 May 29 at 19:51
What works for me was the purple-facebook plugin, a replacement for the builtin Facebook XMPP plugin. See: – Fernando Kosh Jul 28 at 12:33
Sidenote: The above plugin also works on windows – Wouter Oct 12 at 13:35

12 Answers 12

The settings have changed recently.

open pidigin accounts and edit the facebook account to the following:

Protocol: XMPP

Username: xyz (This might not be the username that you enter at facebook login page - But the one which you see on your timeline link -


Resource: Pidgin (this is what is missing most of the time)

Password: xyx

Local alias: xyz

On the advanced tab:

Connect port: 5222

Connect server:

share|improve this answer
Since May 2015 this solution no longer works. On both windows and linux the purple-facebook plugin can be used: – Wouter Oct 12 at 13:34

Facebook itself has a page to help set up several chat clients (or Help search your chat client)

While signed in to Facebook, choose your chat client and you will get a pop-up window telling you the exact settings to enter based on your Facebook login. (for example, username is not the same as what you use to sign into Facebook...)

And just to restate the obvious, I got the "not authorized" after I did the above and realized I had missed a character entering my password...

share|improve this answer
Since May 2015 this solution no longer works. On both windows and linux the purple-facebook plugin can be used: – Wouter Oct 12 at 13:35

I was finally able to find the missing step in solving this:

Apps needs to be enabled on:

Be sure to go through all of this 'App' page and uncheck anything you don't need (i.e. everything).

For the record:

Good luck!

share|improve this answer

When being behind a proxy (not sure if the same for each and every network/proxy config out there) it's worth to try changing "connect port" as well - from default 5222 to 443. This was something that I had to do in order to get it working at my workplace.

So the full config would be:

Basic tab:

 Username: *xyz* (the one that leads to your profile with link like this:
 Domain: **
 Resource: can be blank or *Pidgin* as suggested in facebook's docs
 Password: *your-facebook-password*

Advanced tab:

Connection security: *Require enctryption*
Allow plaintext auth over unencrypted streams: *unchecked*
Connect port: *443*
Connect server: **
share|improve this answer

I'm able to connect from Pidgin to my FB profile, but I couldn't for a friend!

The problem is that my friend has a very long password with a special characters which seems not apparently be accepted by Pidgin (he used the French character ç)

So I reduced password length and delete that strange character, and it works!

If you're obliged to use special characters try the common ones like _ or - or & etc.

Have a nice day!

share|improve this answer

Like the link Alan provided: So credit for the link goes to him.

What worked for me was logging out in my browser and logging in with my username (as opposed to logging in with my email address which I did previously). Crazy that this works. But well, it works, so...

share|improve this answer

Go to security settings onfacebook, create an application password. You probably have a strong password with specialcaracters that facebook doesn't seems to handle well. It solved my problem.

share|improve this answer

This happened after I changed my FB username. ​ led me to change my password, and that solved the problem.

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Oyibo Nov 11 '12 at 8:40

Go to There you can select the IM client you have, in this case Pidgin.

The basic configuration is easy. Take a look to 'Advanced' tab. In my case the field 'connect server' was empty.

Connect server:

share|improve this answer
Your answer is almost identical to the one posted by Stephtech. Is there any way to improve it? – Kevin Bowen Apr 12 '13 at 9:00

i had to use a different username than i usually use in facebook... i would never have imagined this if it wasn't for going to and seeing it in that page... so you gotta go there to see which username to use... greetings... peace... love... and follow the rainbow!

share|improve this answer

I got it works just by following this and removing the value of the File transfer proxies : that is default set for pidgin.

share|improve this answer

Since nobody else has posted this as an answer...

As of May 2015, facebook chat no longer uses XMPP so you can't just use that to connect in pidgin.

Instead, try this plugin:

share|improve this answer

protected by Community May 30 at 7:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.