Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can connect with wired connection in my living room but I can't with my wireless card. I'm pretty sure card is ok because I got a new one and driver works fine. I had Ubuntu 12.04 then I downgraded it to 11.10 and I have the same problem over and over again. I searched all over the forums and I can't find an answer.

 ifconfig
   :eth0      Link encap:Ethernet  HWaddr 40:61:86:35:11:b0  
      inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
      inet6 addr: fe80::4261:86ff:fe35:11b0/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:4096 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3930 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:3959080 (3.9 MB)  TX bytes:591022 (591.0 KB)
      Interrupt:43 Base address:0x6000 

  lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:32 errors:0 dropped:0 overruns:0 frame:0
      TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:2528 (2.5 KB)  TX bytes:2528 (2.5 KB)

wlan0     Link encap:Ethernet  HWaddr f8:d1:11:12:af:79  
      inet addr:192.168.2.5  Bcast:192.168.2.255  Mask:255.255.255.0
      inet6 addr: fe80::fad1:11ff:fe12:af79/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:50 errors:0 dropped:0 overruns:0 frame:0
      TX packets:188 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
          RX bytes:4872 (4.8 KB)  TX bytes:30698 (30.6 KB) 

nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        40:61:86:35:11:B0

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.2.6
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             192.168.2.1


- Device: wlan0  [bitches] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k_htc
  State:             connected
  Default:           no
  HW Address:        F8:D1:11:12:AF:79

  Capabilities:
    Speed:           7 Mb/s

  Wireless Properties
    WEP Encryption:  yes
   WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *bitches:        Infra, CC:5D:4E:DD:33:D0, Freq 2417 MHz, Rate 54 Mb/s, Strength     100 WPA WPA2
*hteronet:       Infra, CC:5D:4E:DD:33:D0, Freq 2462 MHz, Rate 54 Mb/s, Strength 59 WPA WPA2

IPv4 Settings: Address: 192.168.2.5 Prefix: 24 (255.255.255.0) Gateway: 192.168.2.1

DNS:             192.168.2.1
share|improve this question
    
Can you post the output of nm-tool –  tgm4883 Aug 22 '12 at 0:12
    
I have edited the post –  Sandro Livaja Aug 22 '12 at 0:19
    
Can we assume that DNS server works? Are you able to ping 8.8.8.8 –  tgm4883 Aug 22 '12 at 2:24
    
Yes im able to ping it,and no i cant change resolve because system modifies it every time i change it –  Sandro Livaja Aug 22 '12 at 11:12

1 Answer 1

Your DNS server isn't working properly. You have a few options.

  1. Get your DNS server at 192.168.2.1 working properly
  2. Change your router/DHCP server to give out an address to a DNS server that is working properly
  3. Change your computer to use a DNS server that is working properly.

As #1 and #2 aren't Ubuntu specific, I'll give more detail on #3. The system changes resolv.conf because in 12.04 resolv.conf is not generated.

To add a static DNS server, first you need to edit your network connections.

Edit network connections

Next, edit the wired connection

Edit wired connection

Next set it to only get an IP address from DHCP

Addresses only

Last, enter a working DNS server. 8.8.8.8 is a google DNS server that you can use. If you want to add multiple DNS servers here then just separate the IP addresses with a comma.

Add DNS

Once you've added the DNS servers, click save until you get back to the desktop. You should then be able to browse the internet.

share|improve this answer
    
Hey,my wired connection is fine.wireless isnt working. Its probably 1 or 2 –  Sandro Livaja Aug 22 '12 at 17:34
    
So go to the wireless tab instead and do the same thing for the network that isn't working –  tgm4883 Aug 22 '12 at 23:16
    
It isnt working,im so frustrated by this –  Sandro Livaja Aug 23 '12 at 1:36
    
So if you manually place 8.8.8.8 into resolv.conf does it work? That would at least let us know we're working in the right direction. –  tgm4883 Aug 23 '12 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.