Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

UPDATE: (solved- sort of} See my answer below


I have 2 identical USB drives which I've both formatted to identical specs using Gparted. Both have two identical primary partitions (ext4 and ntfs).

  • I have not created any mount-point directories for them.
    (An afterthougt: actually I did, but deleted them, so there are none now. and I did manually mount them (as a test)... Maybe(?) this has done something(?) but there are now no "created-by-me" directories in /media, for these USB drives)

  • There is no mention of them in /etc/fstab.

I want them to auto-mount, and I'd expect them to mount identically...
...but for some reason, the ext4 partitions are mounting with different permissions and different group.

As can be expected with root:root ownership, and no write permission for group/other, it is causing my rsync backup to fail (for usb2).

What might be causing these different mount settings?... (I'm using 10.04)

rsync: failed to set times on "/media/usb2ext4/.": Operation not permitted (1)  
rsync: recv_generator: mkdir "/media/usb2ext4/.Trash-1000" failed: Permission denied (13)  
Skipping any contents from this failed directory  

usb1: 'sudo fdisk -l' -and- 'ls -l /media'  
==========================================
     Device Boot      Start         End      Blocks   Id  System  
  /dev/sdd1               1      108547   871903746   83  Linux  
  /dev/sdd2          108548      121601   104856255    7  HPFS/NTFS  

  drwxrwxr-x 31 root fred 4096 2010-12-17 15:30 usb1ext4  
  drwx------  1 fred fred 4096 2010-12-16 14:04 usb1ntfs  

usb2: 'sudo fdisk -l' -and- 'ls -l /media'  
==========================================  
     Device Boot      Start         End      Blocks   Id  System  
  /dev/sde1               1      108547   871903746   83  Linux  
  /dev/sde2          108548      121601   104856255    7  HPFS/NTFS  

  drwxr-xr-x  2 root root 4096 2010-12-17 10:19 usb2ext4  
  drwx------  1 fred fred 4096 2010-12-16 14:04 usb2ntfs  
share|improve this question

1 Answer 1

up vote 3 down vote accepted

Problem solved! (sort of...)

... I've been doing some very deliberate and detailed tests for several hours now (including manually mounting the drives, as well as the auto-mount), and always with the same results.. Repeatable reslults!... until I tried something which shouldn't make a difference, but it did!

... I simply plugged in the "problem" drive on its own, and it mounted perfectly (on its own)! .. okay, so I then plugged in the other drive and it too mounted perfectly! ... I've subsequently rebooted, plugged, unplugged, and mounted, and unmounted (via Nautilus).. and all is working fine now

... There's nothing quite like a good mystery! ...( and OMG! I certainly have learnt a lot about mounting tonight! ... It was worth it alll, just for that :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.