Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Why is “No new release found” when upgrading 10.04 to 12.04 LTS?

i am not seeing 12.04 LTS available for update in Update Manager. i followed the update instructions, and set to lts release only. when on normal release, i see only 10.10. i wish to upgrade to 12.04 LTS.

what am i missing?

my data is backed up, but i have at least 2 yrs of programs installed and i would not like to lose all those programs and configs for various services and such. otherwise i would do a clean install.

suggestions? or more specific instructions please.

thanks. pete

share|improve this question

marked as duplicate by Thomas W., Jorge Castro, Mitch, Uri Herrera, stephenmyall Aug 24 '12 at 8:55

This question was marked as an exact duplicate of an existing question.

    
What Ubuntu version are you running at this time? – Mitch Aug 21 '12 at 19:27
    
10.04 LTS currently. – olyanderson Aug 21 '12 at 19:28
    
um... why did you close? there is no exact duplicate... i did the update path from 10.04 > 10.10 > 11.04 > and as you may have guessed by now, THERE IS NO UPGRADE PATH TO 12.04 LTS - per all your instructions, sudo cmd's ecterra... bottom line, something is janked up in the apt or update configs and is a bug of sorts. reopen this ticket. also, if you can post the example of exactness, i would enjoy taking at look at. remember, i followed your instructions, and no 12.04 LTS ever shows up. i'll be awaiting your responses... thanks, oly – olyanderson Aug 24 '12 at 21:04
    
further more i am currently at 11.04 and im already see degradation in simple functions, like bash not tab completing properly... help! – olyanderson Aug 24 '12 at 21:07
    
what worked for someone else, obviously isnt working for me... keep that in mind ... – olyanderson Aug 24 '12 at 21:07

Make sure that you have a Backup of everything you absolutely can't afford to lose.

Then just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get update

sudo apt-get dist-upgrade

Then see if you have the option to upgrade to 12.04. If not then

do-release-upgrade -d

Update: if the above gives you trouble, try:

sudo apt-get update && sudo apt-get upgrade

sudo apt-get install update-manager-core

do-release-upgrade -d
share|improve this answer
    
after doing the above, it states 10.10, not 12.04 LTS. What am i missing? thanks – olyanderson Aug 21 '12 at 22:59
    
awaiting the next step, do-release-upgrade -d did not set to 12.04 LTS. – olyanderson Aug 22 '12 at 17:39
    
Try update-manager -d – Mitch Aug 22 '12 at 17:49
    
nope, still no 12.04 LTS option,,, ponders why it was closed. becuz i didn't do it fast enough? that's really bad support to close a ticket without resolution or feedback from the last cmd avised to execute..... sighs... – olyanderson Aug 24 '12 at 21:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.