Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here I got a problem.

I have a Wireless Router which is Buffalo WCR-HP-GN, and I setting a WIFI which use WPA2-PSK authentication and the passphrase encrypted by TKIP. The password is a 9-letter numbers.

My wife has a macbook, and it can connect to the wifi. But my lenovo x200 with Ubuntu 12.04 LTS can not connect to the wifi. I checked the setting and IP, everything is fine. I can get the IP through dhclient, but when I try to ping the gateway, it does not work. If I try to connect it with wired ethernet cable, and everything is fine, I can ping the gateway.

Can anyone tell me what's happened and how to solve it ? Thanks !!

Here is the dmesg log while I connect to the wifi.

[85315.000578] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[85315.616173] usb 4-2: new full-speed USB device number 35 using uhci_hcd
[85321.433260] wlan0: authenticate with 4c:e6:76:5f:74:ff (try 1)
[85321.448196] wlan0: authenticated
[85321.449359] wlan0: associate with 4c:e6:76:5f:74:ff (try 1)
[85321.455113] wlan0: RX AssocResp from 4c:e6:76:5f:74:ff (capab=0x411 status=0 aid=2)
[85321.455122] wlan0: associated
[85321.463260] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[85321.464451] cfg80211: Calling CRDA for country: GB
[85321.475841] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
[85321.475852] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475859] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
[85321.475866] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475872] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
[85321.475879] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475885] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
[85321.475892] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475898] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
[85321.475905] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475911] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
[85321.475918] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475924] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
[85321.475931] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475937] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
[85321.475944] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475950] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
[85321.475957] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475963] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
[85321.475970] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475976] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
[85321.475983] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.475989] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
[85321.476029] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476035] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
[85321.476042] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476049] cfg80211: Updating information on frequency 5180 MHz for a 20 MHz width channel with regulatory rule:
[85321.476058] cfg80211: 5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476065] cfg80211: Updating information on frequency 5200 MHz for a 20 MHz width channel with regulatory rule:
[85321.476074] cfg80211: 5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476082] cfg80211: Updating information on frequency 5220 MHz for a 20 MHz width channel with regulatory rule:
[85321.476090] cfg80211: 5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476098] cfg80211: Updating information on frequency 5240 MHz for a 20 MHz width channel with regulatory rule:
[85321.476107] cfg80211: 5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476115] cfg80211: Updating information on frequency 5260 MHz for a 20 MHz width channel with regulatory rule:
[85321.476123] cfg80211: 5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476131] cfg80211: Updating information on frequency 5280 MHz for a 20 MHz width channel with regulatory rule:
[85321.476139] cfg80211: 5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476147] cfg80211: Updating information on frequency 5300 MHz for a 20 MHz width channel with regulatory rule:
[85321.476155] cfg80211: 5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476163] cfg80211: Updating information on frequency 5320 MHz for a 20 MHz width channel with regulatory rule:
[85321.476171] cfg80211: 5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[85321.476179] cfg80211: Updating information on frequency 5500 MHz for a 20 MHz width channel with regulatory rule:
[85321.476187] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476194] cfg80211: Updating information on frequency 5520 MHz for a 20 MHz width channel with regulatory rule:
[85321.476203] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476211] cfg80211: Updating information on frequency 5540 MHz for a 20 MHz width channel with regulatory rule:
[85321.476220] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476227] cfg80211: Updating information on frequency 5560 MHz for a 20 MHz width channel with regulatory rule:
[85321.476236] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476244] cfg80211: Updating information on frequency 5580 MHz for a 20 MHz width channel with regulatory rule:
[85321.476252] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476260] cfg80211: Updating information on frequency 5600 MHz for a 20 MHz width channel with regulatory rule:
[85321.476269] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476276] cfg80211: Updating information on frequency 5620 MHz for a 20 MHz width channel with regulatory rule:
[85321.476285] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476293] cfg80211: Updating information on frequency 5640 MHz for a 20 MHz width channel with regulatory rule:
[85321.476301] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476308] cfg80211: Updating information on frequency 5660 MHz for a 20 MHz width channel with regulatory rule:
[85321.476317] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476324] cfg80211: Updating information on frequency 5680 MHz for a 20 MHz width channel with regulatory rule:
[85321.476334] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476341] cfg80211: Updating information on frequency 5700 MHz for a 20 MHz width channel with regulatory rule:
[85321.476350] cfg80211: 5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A mBi, 2700 mBm)
[85321.476356] cfg80211: Disabling freq 5745 MHz
[85321.476362] cfg80211: Disabling freq 5765 MHz
[85321.476367] cfg80211: Disabling freq 5785 MHz
[85321.476372] cfg80211: Disabling freq 5805 MHz
[85321.476377] cfg80211: Disabling freq 5825 MHz
[85321.476390] cfg80211: Regulatory domain changed to country: GB
[85321.476396] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[85321.476404] cfg80211:     (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[85321.476412] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[85321.476419] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[85321.476427] cfg80211:     (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[85326.605714] iwlwifi 0000:03:00.0: Tx aggregation enabled on ra = 4c:e6:76:5f:74:ff tid = 6
[85331.952112] wlan0: no IPv6 routers present

This is the dhclient log

$ sudo dhclient wlan0 -v
Internet Systems Consortium DHCP Client 4.1-ESV-R4
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/
Sending on   LPF/wlan0/
Sending on   Socket/fallback
DHCPREQUEST of 192.168.11.3 on wlan0 to 255.255.255.255 port 67
DHCPACK of 192.168.11.3 from 192.168.11.1
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
bound to 192.168.11.3 -- renewal in 69538 seconds.

The routing table:

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.11.1    0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.11.0    0.0.0.0         255.255.255.0   U     2      0        0 wlan0

I cannot ping through wireless connect:

$ ping 192.168.11.1
PING 192.168.11.1 (192.168.11.1) 56(84) bytes of data.
^C
--- 192.168.11.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms

I can ping through wired connect:

$ ping 192.168.11.1
PING 192.168.11.1 (192.168.11.1) 56(84) bytes of data.
64 bytes from 192.168.11.1: icmp_req=1 ttl=64 time=0.988 ms
64 bytes from 192.168.11.1: icmp_req=2 ttl=64 time=0.811 ms
64 bytes from 192.168.11.1: icmp_req=3 ttl=64 time=0.820 ms
64 bytes from 192.168.11.1: icmp_req=4 ttl=64 time=0.860 ms
^C
--- 192.168.11.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 0.811/0.869/0.988/0.079 ms
share|improve this question

2 Answers 2

I try to figure out the problem, and I found there has a lot of signal on the same channel which I use.If I change the channel, I can ping the router IP. I will edit this answer while I can get detail log :)

share|improve this answer

Try connecting wirelessly, then using another device to view the router page and see if it lists your host as connected.

Also, I'm seeing this in your logs:

192.168.11.3

Is this the IP address assigned to your computer? If so, try assigning a static IP from your router to that computer's MAC address, or set the static IP in Ubuntu. Change it to something within the router's domain, such as

192.168.11.13

(assuming, of course, that that IP isn't already taken)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.