Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I started to use Ubuntu in April. I thought it would give me the option whether to boot into Ubuntu or Windows at each start. But that didn't happen. But I was happy with Ubuntu and didn't have time so I didn't try to get dual boot working.

Now my father has stepped up pressure on me to either have a dual boot working or remove Ubuntu.

2 months back I tried repairing Windows (was suggested by a friend) by using the CD but still I didn't get the dual boot option.

Recently, after searching the web I found out that a lot of people do use dual boot but I still don't get what I should do even after searching a lot

I have 2 hard drives, the primary has Ubuntu 12.04 LTS as well as Windows 7. In the secondary hard drive there is another Windows 7 installed.
All I want is to have the option to boot on of the OS in my primary hard disk only.

I took help from the people Ubuntu servers in Xchat. They asked me for the following things:

  1. To open GParted and screen shot of it
  2. grub.cfg in /boot/grub
  3. grub file in /etc/default/grub
  4. Video of how my computer boots up

I am writing the links for these (according to the numbers up)

  1. http://www.4shared.com/photo/79wMbZvw/Screenshot_from_2012-08-21_174.html?refurl=d1url
  2. http://paste.ubuntu.com/1159285/
  3. http://paste.ubuntu.com/1159386/
  4. http://youtu.be/-Jzr6_HAJEU [the thing written in the middle of the video (when the rectangle box appears)is - "ATENCION"(1st line) "92K/58HZ"(2nd line) "FREQUENCIA FUERA DE MARGEN"(3rd line)] check this clear pic -

http://www.4shared.com/photo/XnhOte2Q/21082012002.html?refurl=d1url

The helpful people out there came to the conclusion that my monitor is old and unsupported for dual boot.

Somehow I couldn't digest that so please examine things out and help me out.
People its even your responsibility to save a Ubuntu fan like me.

share|improve this question
    
Based on your gparted screenshot it doesn't seem like you've 2 hard disks. Also there is no need of 2 swap partitions. –  green7 Aug 21 '12 at 16:47

2 Answers 2

up vote 4 down vote accepted

The Monitor is saying "Attention 92K/58HZ Frequency out of range." This means the monitor is not able to display the Grub menu as the Grub is sending it in a form that the monitor can't recognize.

Try the following:

gksu gedit /etc/default/grub

Uncomment (delete the # from the beginning) the following line.

# GRUB_TERMINAL=console

Save and exit gedit.

Use the update-grub command:

sudo update-grub

Reboot.

If at any of these setting changes the computer becomes unbootable, you will have to boot from Ubuntu Live CD (Try Ubuntu) and revert the changes in /etc/default/grub in your hard drive.

Explanation: When you boot the computer first the BIOS loads. Then GRUB loads. At this stage no OS is loaded and the computer has limited graphics capability. By default GRUB assumes the monitor can handle some graphics without the help of CPU, as most modern monitors can.

This monitor is very old and cannot handle the default display resolution of the GRUB menu. So it was showing the error message while GRUB was trying to show the menu choices. Since you couldn't see the menu, you waited till GRUB timed out and loaded the default OS Ubuntu. By commenting out the line GRUB_TERMINAL=console we told GRUB to display the menu in old "text-mode" style that your monitor can display without any help from the CPU.

share|improve this answer
    
Thanks people it worked (deleting # from # GRUB_TERMINAL=console) -now only thing was windows was a bit slow but that may be due to the fact that I started it after months. If any problems arise I will inform you - thanks a lot –  Udayan Sanyal Aug 21 '12 at 18:03
    
Please indicate uncommenting which of the two lines (or both) worked. I will edit the answer accordingly for future reference. And accept the answer as the "Accepted." Thanks. –  user68186 Aug 21 '12 at 18:06
    
deleting # from # GRUB_TERMINAL=console –  Udayan Sanyal Aug 21 '12 at 18:08
    
I have 2 supplementary questions- 1)Is it possible that if I do a software update the grub might become the same as it was or there is very less possibility of the grub file(in default) being edited though an update? 2)I am planning to buy a new monitor in next 1 month so do I put the # back if I switch my monitor to a latest one(to get a better graphical grub menu )? –  Udayan Sanyal Aug 21 '12 at 19:52
1  
1) It is unlikely that a software update will change the grub config files on its own. Grub does not get updated frequently. If it does it should let you choose between the existing and the new default config. 2) When you get a new monitor putting the # back should give you nicer fonts etc. I don't think the menu itself will be any different. –  user68186 Aug 22 '12 at 1:46

Clearly, your grub.cfg doesn't contain an entry for Windows and it shouldn't be, because Windows is on another hard drive.

You need to manually edit your grub.cfg file.

  • Run sudo lshw -C disk and find out the Physical id of the hard disk which has Windows installed.

lshw -C disk

  • Open grub.cfg in a text editor with root permissions (example, sudo gedit grub.cfg).

  • Add the following entry in the file:

    menuentry "Windows 7" {
        set root=(hdX,msdosY)
        chainloader +1
    }

    Here, X is the physical id of the hard drive, and Y is the partition number where Windows is installed.

Restart and test.

share|improve this answer
    
Mr green7 i have 3 OS in my 2 hardisks- 1ubuntu and 1 win7 in primary HD and 1 win7 in 2nd HD and i dont even get the option to boot into the win7 present in my primary HD only ubuntu opens –  Udayan Sanyal Aug 21 '12 at 16:53
1  
did you try the above commands from Ubuntu? –  green7 Aug 21 '12 at 16:59
    
The commands didnt work and the screen shot was only of the primary hard drive. Is the second one required too –  Udayan Sanyal Aug 21 '12 at 17:07
    
Contents of /etc/default/grub are in paste.ubuntu.com/1159386 –  Udayan Sanyal Aug 21 '12 at 17:17
    
Mr user68186 this is the thing written are "ATENCION"(1st line) "92K/58HZ"(2nd line) "FREQUENCIA FUERA DE MARGEN"(3rd line) I dont know what it is –  Udayan Sanyal Aug 21 '12 at 17:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.