Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install the regular updates on my Ubuntu 12.04 but for some reason I keep getting this error. Any Idea how I can resolve it?

error

share|improve this question
1  
Run sudo apt-get update in a terminal first, then run sudo apt-get dist-upgrade and paste the output here. CLI programs tend to be more verbose when they encounter a problem. –  InkBlend Aug 21 '12 at 16:30
add comment

1 Answer 1

up vote 1 down vote accepted

It looks like you are missing the key for the qgis repo. Assuming you installed it using the repo found here, just add the key, like this:

gpg --keyserver keyserver.ubuntu.com --recv 997D3880
gpg --export --armor 997D3880 | sudo apt-key add -

You will then need to run update apt, and it should work.

sudo apt-get update
share|improve this answer
    
Thanks that solved it. Also I had to take @InkBlend advise as well. After executing your commands I also executed sudo apt-get update and sudo apt-get dist-upgrade –  Sam007 Aug 21 '12 at 16:42
1  
Np, I forgot to add the apt-get update part. The dist-upgrade isn't exactly necessary, since you are doing the same thing through the GUI when you run updates. I updated my answer in the hopes it will help someone else. –  reverendj1 Aug 21 '12 at 16:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.