Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
notify-osd and dual monitors

I have two monitors setup currently however when I get a new notification (ie popup for new mail, or im) it fades in on the secondary monitor and fades out on the secondary monitor.

Is there any way to change it so that the notification alerts appear on the primary not secondary monitor?

I'm using a ATI card if that even makes a difference :)

share|improve this question

marked as duplicate by Tom Brossman, John S Gruber, RolandiXor, Mitch, con-f-use Sep 9 '12 at 10:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 6 down vote accepted
+50

To make the notification work properly on the primary monitor. You may need to update the scema-key notifyosd under com.canonical

Open a terminal and use the command below:

gsettings set com.canonical.notify-osd multihead-mode "focus-follow"

or alternatively, if you have dconf-tools installed then :-

  • Open dconf-editor and

  • Navigate to appsnotify-osdmultihead-mode and change the value to focus-follow.

    By setting this you can make the notification bubble appear on the display which currently has focus.

To have dconf-editor, use command sudo apt-get install dconf-tools in a terminal or click the link here → dconf-tools Install dconf-tools.

share|improve this answer
    
Can you make it just appear in a specific monitor rather than focus follow? Also is there docs for this setting anywhere? –  John Mitchell Aug 31 '12 at 12:45
    
Unfortunatley this doesn't appear to work :| error is sudo gsettings set com.canonical.notify-osd multihead_mode "focus-follow" No such key 'multihead_mode' –  John Mitchell Aug 31 '12 at 12:50
1  
Check this launchpad bug and see comment #13 –  devav2 Aug 31 '12 at 12:59
2  
Your problem is that the key is called multihead-mode not multihead_mode. I don't think schemas use underscore characters –  Ian B. Aug 31 '12 at 14:19
    
This appears to be working now, its still a bit buggy (the notification overlaps the status bar unlike in single monitor mode), but I'm hoping that will be solved over time. I also used dconf instead of gconf (since gconf doesn't show the key). –  John Mitchell Aug 31 '12 at 14:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.