Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 with many DE. Lubuntu is one of them. I don't have any option to lock screen in Lubuntu while I do in Unity and other DE.

Is there any program / application that I can install in order to lock screen in Lubuntu?

share|improve this question
    
Have you installed lubuntu-desktop or only lxde? –  Anwar Shah Sep 12 '12 at 6:23
    
actually both but I've that application in my list of apps because I've got more environments installed as gnome shell , unity and kde recently . –  AgentCool Sep 12 '12 at 7:13

5 Answers 5

up vote 5 down vote accepted

I just use the keybindings I've always used on ubuntu. Press: Ctrl + Alt + L

Should work

share|improve this answer
    
Cool man +1 , i have tried and Its worked . But are sure about this , that it will work in Lubuntu too ? –  AgentCool Nov 7 '12 at 12:43
    
this is a keybinding. he asked for "program/application". It gives him a good start on finding the answer he is seeking, but doesnt tell him where to look though (openbox configuration file). –  Joshua Kersey Dec 28 '12 at 21:54

There is an article at the here at the LXDE forums. It gives instructions on creating a .desktop file to lock the screen, and adding it to the top panel.

share|improve this answer
    
hey i have tried that & did as it said but i am not getting screen lock option while with application launcher option . –  AgentCool Aug 24 '12 at 19:12

Try installing lubuntu-default-settings package. Open a terminal and run this command:

sudo apt-get install lubuntu-default-settings

This should fix the problem.

share|improve this answer

There are several ways of doing it. The easiest being:

LXDE Menu - Other - Lock Screen (XScreensaver).

HTH.

share|improve this answer

The lxlock program provides screen locking functionality in LXDE.

It is part of lxsession. The lxsession Install lxsession package provides it.

Try running lxlock from the Run dialog (Alt+F2 or LXDE Menu > Run) or the LXTerminal (Alt+F2).

If lxlock locks the screen, you can work around the problem by running it that way or by creating a launcher for it on the menu, panel, or desktop.

If lxlock runs but does not lock the screen, that's probably a bug.

If lxlock is not present on your system, run this to install (or, if it's installed but damaged, to reinstall) the lxsession package:

sudo apt-get update && sudo apt-get --reinstall install lxsession

After installing that, lxlock should work, but if it runs and fails, try logging off and back on to see if that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.