Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently, I was meddling with ccsm and the window kept refreshing with every plugin addition (which is normal i suppose). However, after i enabled SVG (I dont think this is relevant but i included it anyway) under image loading, suddenly it got hung! Unity crashed, as i couldn't see a top bar or a launcher! My window decorations were out too! I restarted the computer hoping it would fix anything, but it didn't work!

Right now, all i can see on the screen in my mouse, the wallpaper and my desktop icons. Right click works for me, and i can drag icons around the desktop. I can even run chrome (using docky which works too (except its in 2D, not in 3D))

I tried using unity --reset and unity --replace from the recovery console, but every time it hung.

Initializing core options...done

When I tried running compiz --replace, it came back with this

compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Fatal: Couldn't open display
compiz (core) - Info: Stopping plugin: core
compiz (core) - Info: Unloading plugin: core

When I try running metacity --replace:

Window manager error: unable to open X display

When I try to run ccsm from the recovery, It doesn't start up

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/ GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
File"/usr/lib/python2.7/dist-packages/ccm/", line 1, in <module>
  from ccm.Conflicts import *
File"/usr/lib/python2.7/dist-packages/ccm/", line 26, in <module>
  from ccm.Constants import *
File"/usr/lib/python2.7/dist-packages/ccm/", line 30, in <module>
  CurrentScreenNum = gtk.gdk.display_get_default().get_default_screen().get_number()
AttributeError: 'NoneType' object has no attribute 'get_default_screen'

Please help me, and ask if you need any more info. XD

Thanks a ton! Ciao

share|improve this question

I found out how to solve. Pretty funny though!

It was quite simple actually, rather than trying to launch ccsm from the recovery console, i started nautilus (From Docky, which was working for me), and went to "Computer/usr/bin" (On Ubuntu 12.10). From there I could launch ccsm and found out that all plugins were disabled. I went ahead and added in unity and other plugins, and everything's back to normal!

Hope this helps everyone who has a similar problem!

Ciao! Pranay

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.