Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm thinking of replacing my elderly Dell Dimension 5150 with an XPS 8500, but the only reference to this PC's compatibility with Ubuntu mentions to a video failure on booting up, with no solution recorded.

Has anyone installed Ubuntu 12.04 on this model?

share|improve this question
Having a problem myself on my own machine XPS 8500, 2TB HDD, 16GB RAM, Win7 Home premium then upgraded in place to Windows 8 Pro, 32GB SSD (Cache drive) and the last one is the problem... I could never installed Ubuntu successfully using WUBI installer as I don't want to do any partitioning... Will crawl some more to get an answer – Ahmadgeo Mar 25 '13 at 1:44
Installed an additional SATA HDD and tried to install on it directly (no WUBI) and still failing. – Ahmadgeo Mar 31 '13 at 4:59

I didn't. However, running a live Ubuntu system from a flash drive or CD costs you next to nothing. If your graphics, wireless, ethernet and power management work with a live system, then they will also work with a normal installation. Moreover, the older the system is, the less trouble you should expect.

share|improve this answer
I'm thinking of replacing my elderly computer with a current model, so the experiment will cost me >£1000! I'm hoping someone else has already taken the plunge... – user69245 Aug 21 '12 at 19:39

I have. It took a little doing. The problem is with the drivers for the video card. The following steps worked for me (note my machine has an nvidia geforce gt 620):

first standard install cd did not work so use the alternate cd ( After install normal start up breaks just before log in screen. Instead boot into recovery mode and select "drop to root shell prompt" and type "restart." Now log in screen is displayed. Log in and install the nvidia 295.33 driver (

share|improve this answer
what is your exact PC model? The question is on DELL XPS 8500/Elite edition that is with SSD Cache drive + 2TB Hard Drive.... The problem with this model is in installation itself as it doesn't recognize HDD partions and fails installing GRUB.... Not in display drivers :).... – Ahmadgeo Apr 5 '13 at 17:20

I have XPS 15z and I had to do the following:

  • during boot select the acpci=off with F6 (otherwise the booting hangs)

  • Keyboard doesn't work. Connect a mouse, open

    • vitual keyboard

    • terminal

    type in terminal:

    sudo kate /etc/default/grub

    in there add change the following line



    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor dell_laptop.backlight=0 acpi=noirq"


  • run

    sudo update-grub

    Then on reboot You'll have keyboard working.

As to Your video card -- Radeon -- I think It will be solvable (I have Nvidia).

share|improve this answer
thanks for your reply. But we are talking here about a DELL XPS 8500 Desktop Computer :) – Ahmadgeo Mar 28 '13 at 16:00
Ok. Still -- I had to acpci=off also on some Samsung ultrabook -- so it might be common. – Adobe Mar 28 '13 at 17:18

I got duo Windows 7 / KUbuntu on my dell M8500.

My KUbuntu basically can replace Windows on all my daily development and entertainment. I evens has Office 2010, and all the tools I need (except Visual Studio)

I used Kubuntu daily and the only major issue is the video card driver (AMD Radeon HD 7570). One times / 10 after reboot, the VGA crapped at the login screen, and I have to reboot again (blindly via command line) to get back to normal

Here is my experiences on installation of Ubuntu on this machine

You might lost 1 week of frustrating to get Ubuntu the way you want, and working on a stranger OS might not as productive as your familial OS. For me, I love to test, and as a .NET developer for my daily work, I tried to get out of Windows OS at home, and taste other techno

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.