Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Linux newbie, and this is the first time I am using TOR in 12.04. I have an issue in running TOR for which I couldn't find any specific answer in the Internet.

So let me explain.

  1. I downloaded TOR browser bundle (tor-browser-gnu-linux-x86_64-2.2.38-1-dev-en-US.tar.gz) and saved to this location: /media/50B8245BB82441B8/TOR/

  2. I then extracted tar.gz file into the same directory. So now I have /media/50B8245BB82441B8/TOR/tor-browser_en-US

In this directory, there is a file start-tor-browser. The problem is that, when I double click this file, it opens in text format, instead of launching TOR Vidalia.

So I right-clicked this file > Permissions > checked Allow executing file as program, but again it automatically unchecks it.

I then thought of executing this file through the terminal, but nothing seems to work.

cd /media/50B8245BB82441B8/TOR/tor-browser_en-US    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ start-tor-browser    
start-tor-browser: command not found    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ cd start-tor-browser    
bash: cd: start-tor-browser: Not a directory    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ sudo start-tor-browser    
[sudo] password for jerry:     
sudo: start-tor-browser: command not found    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ gksu start-tor-browser    
jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$

As you can see, when I use gksu, nothing really happens except an empty command line added with a blinking cursor.

Can someone please help?

share|improve this question
2  
out of curiosity what architecture is your computer? EDIT: Also, I'm not sure but I believe to run something you need to place a "./" before it. –  KI4JGT Aug 21 '12 at 6:48
    
AMD Athlon 64 X2 Dual Core Processor 5000+, 2GB RAM –  Jerry-bliss Aug 21 '12 at 7:16
    
Do what damien has stated above and then try the 32 bit version of the TBB if his suggestion doesn't work. I'm also running a 64bit machine but whenever I try to download Tor it defaultly gives me the 32bit version of the program. –  KI4JGT Aug 21 '12 at 7:21
    
I tried, it did not work and here is the error message. Launching Tor Browser Bundle for Linux in /home/gpsvn/Desktop/tor-browser_en-US start-tor-browser: 228: start-tor-browser: ./App/vidalia: Permission denied Vidalia exited abnormally. Exit code: 126 –  user149013 Apr 13 '13 at 10:03
    
@Jerry-bliss /media/50B8245BB82441B8/ is a USB key right? Could you try from your hdd. Your problem might be related to this Q&A –  danjjl Apr 13 '13 at 10:12
show 2 more comments

7 Answers

It seems that the device you have extracted it on does not support permissions (is not a native Linux filesystem). Re-extract the tar.gz but do it in your home directory (home directory should support permissions).


DO NOT JUST COPY THE FILES FROM WHERE YOU EXTRACTED THEM! IT WILL NOT WORK!

share|improve this answer
2  
Yes this is a common problem. It wasn't being executed because OP was trying to execute it from external media. Try running it after extracting it to your Desktop. –  Sheharyar Jun 16 '13 at 21:40
    
If you just copy it, the "new" permissions - not executable - will be copied and it still won't work. –  saleemrashid1 Jun 25 '13 at 7:27
add comment

All you have to do is double click the start-tor-browser file and click run when prompted and it will start. It obviously needs to be executable.Maybe root owns directory change ownership sudo chown -R <username>:<groupname> path/to/tor-directory Make executable cd path/to/tor-directory chmod +x start-tor-browser double click on start-tor-browser click run and it should start up.

share|improve this answer
    
When i dblclick start-tor-browser file, it immediately opens the textfile content without any prompting. And what is <groupname>? Should it be ubuntu? –  Jerry-bliss Aug 21 '12 at 8:11
1  
This would be because its not executable you said it wouldn't stay clicked on when you tried to change permissions which made me believe root owned the directory . What you originally tried would work if you gksu nautilus go to tor directory and changed to executable. you could also change the owner and group to jerry whilst there or how i originally said replacing <username>:<groupname> for jerry:jerry –  damien Aug 21 '12 at 8:34
    
thanks, but still doesn't seem to work.... jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ sudo chown -R jerry:jerry /media/50B8245BB82441B8/TOR/tor-browser_en-US [sudo] password for jerry: jerry@ubuntu:/media/50B8245BB82441B8/TOR/tor-browser_en-US$ cd /media/50B8245BB82441B8/TOR/tor-browser_en-US chmod +x start-tor-browser ....... Nothing happens after that –  Jerry-bliss Aug 21 '12 at 10:33
    
Screenshot: mediafire.com/conv/… –  Jerry-bliss Aug 21 '12 at 11:23
    
Hi jerry i thought it may be because it appears you have TOR on another partition or usb that could be causing the issue.However i was still able to change owners and permissions placing it on another partition on my system.How is that drive formated? Try copying the tor-browser_en-US directory and place it in your home or downloads folder instead of another partision. Then try changing permission again from there and see if it then works. –  damien Aug 22 '12 at 1:13
show 2 more comments

Type this:

sh [directory]/start-tor-browser
share|improve this answer
add comment

What I did was just open up the terminal and drag the file start-tor-browser into it and it started up from there.

share|improve this answer
add comment

It's harder, because, in Ubuntu 12.04, it seems that unity does not allow the execution of the start-tor script. I've found a solution modifying what was suggested here: http://www.scribd.com/doc/85715850/How-to-Install-and-Configure-Tor-on-Ubuntu-11

These are the steps: download tor, browse bundle and extract wherever you want, let say in your home direcory that is: /mypc/myhome/

Then open gedit and write in a new file this code:

#!/bin/sh
[Desktop Entry]
Name=Vidalia-TorClient
Comment=Browse the internet Anonymously
Exec=/mypc/myhome/tor-browser_en-US/start-tor-browser %U
Icon=/mypc/myhome/tor-browser_en-US/Data/Vidalia/icon.png
Terminal=false
Type=Application
Categories=Application;WebBrowser

save the file with the name Vidalia.desktop

in a terminal input

gksudo nautilus

so you have a file browser with the privilege of administrator, now copy the Vidalia.desktop file in

/mypc/myhome/.local/share/applications/

Close nautilus and now in your Unity application window you will have an icon with the name Vidalia, click on it and you will have you TorBrowser

share|improve this answer
add comment

I had the same issue. No matter what I did the start-tor-browser file would always open as text.

Here's the fix (in Ubuntu Desktop 13.04):

  1. Open directory "tor-browser_en-US" in file manager window, navigate to the top menu bar of your screen and click on "Files".
  2. Click on "Preferences", select the "behavior" tab, and change setting to "Run executable text files when they are opened".

The default setting is to "View executable text files when they are opened" and that is why it opens as text file.

share|improve this answer
add comment

Navigate to the top menu bar of your screen and click on Files.

Click on Preferences → select the behavior tab → change setting to "Run executable text files when they are opened"

The default setting is to "View executable text files when they are opened" and that is why it opens as text file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.