Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 today. I had installed Ubuntu many a times and uninstalled it again because I couldn't connect to the Internet. I tried configuring the DSL in Ubuntu, but it failed. I configured wired connections and it got connected. Then when I Connect to DSL, the wired connection gets Disconnected. Its very confusing as in: What is Wired Connection and what is DSL? My Windows Network setting looks like the one in the image. Please someone help me in configuring it in Ubuntu.

This is the Dialler setting which I use to connect to the net.

This is my LAN setting.

This is the output of ifconfig

rakz@ubuntu:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:e0:4d:c2:30:7e  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:41 Base address:0xa000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5120 (5.1 KB)  TX bytes:5120 (5.1 KB)

This is the output of cat /etc/network/interfaces

    auto lo
iface lo inet loopback


iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth0
iface eth0 inet manual
share|improve this question
    
The images are of a Windows Network. Can you include the output of ifconfig in your question? –  Mitch Aug 21 '12 at 6:30
    
Windows ipconfig or ubuntu ifconfig ? –  Rakz Aug 21 '12 at 6:48
    
Ubuntu ifconfig –  Mitch Aug 21 '12 at 6:51
add comment

1 Answer 1

In Edit Connectios make sure the Connection Name is Auto(eth0)ie ethzero-MTU is set to automatic-IPv4 settings are Method: Automatic(DHCP), both boxes are ticked for 1.Require IP4 addressingfor this connection to complete, and2.Available to all users, In IPv6 settings, make sure Method: is set to Ignore, and tick the box for Available to all users.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.