Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Configuration:

MBB: ASRock X79 Extreme6

  • Win 7 installed on a INTEL 40GB SSD (GPT partitioned)
  • Ubuntu 14.04 on a CORSAIR 30GB SSD (Ext4 and SWAP)

I had Windows 7 installed previously in UEFI mode, using 3 partitions (GPT) and works fine if left alone. In UEFI BIOS settings I can see sometimes a "Windows Boot Manager" and other times (?) a "UEFI Intel" entry for INTEL HDD and Windows will boot properly selecting the one available at that time.

I installed Ubuntu 14.04 after Win 7 w/o changing any UEFI BIOS settings and it works fine only if the BIOS is set w/ the Ubuntu partition as the first drive to boot, in AHCI mode.

If both SSD drives are connected, the Win7 Intel boot drive can be chosen as first boot device but only as an "AHCI Intel drive" (No "Windows Boot Manager" nor "UEFI Intel device" options available in BIOS Boot menu) and Win7 will not load properly as long as the Ubuntu Crucial SSD is NOT PHYSICALLY DISCONNECTED. Windows will try, start booting for few seconds but will fail replacing Win7 logo and that startup animation with w/ the "old" white progress bar and then and will notify that there is a issue and prompt the user to try to Load Win 7 in Normal Mode again or try a Recovery Mode to fix it.

If I let Windows INTEL HDD boot via BIOS/UEFI - Windows Boot manager selection, I may see the purple screen of Grub2 loaded for a while, but there's no selection for Ubuntu or Windows and/or then machine is not booting, showing a black screen and a small command prompt cursor blinking on top.

So far the only option I see to have Ubuntu boot side by side w/ Win 7 is to reformat the Win7 SDD and set it boot in legacy BIOS mode with a MBR instead of GPT. Per my understanding this is a quite complex issue to fix (Rod Smith's answer was pretty helpful: UEFI boot on my Asus k52f) but any other suggestions are welcome.

I find a bit odd that I can boot properly Windows7 SSD or an Ubuntu DVD using a DVD drive set in UEFI-BIOS in "AHCI mode" and w/ using "UEFI/Windows Boot Manager" booting option but I cannot boot a secondary SSD-HDD w/ Ubuntu having the same BIOS/UEFI Boot configuration. Looks like plugging the second SSD [the Ubuntu partition] is interfering with boot options in UEFI-BIOS.

share|improve this question
add comment

2 Answers

You don't necessarily need to dual boot Windows and Linux on UEFI. Follow the guide http://www.youtube.com/watch?v=PEou2dIcMSE to convert your UEFI to MBR-BIOS without loss of data.

This guide has been made by me. Also, the referred blog will never be taken down. Although I have used it like 10 times without any loss of data, I would recommend you to backup your data before using my procedure.

share|improve this answer
    
Could you have your answer refer to your blog entry as well? –  John S Gruber Oct 9 '12 at 17:25
    
add comment

I reverted the Windows SSD to MBR and everything went back to normal. I don't miss the UEFI w/ GPT partitioning anyway since while using MBR the boot time is faster for Win7 while using MBR (20s). Ubuntu boots in 15s and there's no longer any conflict among WIn7 and Ubuntu drives.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.