Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I have been trying to put bridge mode on ubuntu basically my setup I've got a router upstairs that I usually get wireless to my laptop which is connected ethernet to my ps3, so my ps3 gets connected through my laptop

             ethernet

WIFI ---- LAPTOP ----------- PS3

Now on winxp this doesn't pose me a problem at all I just select local area connection and the wireless connection just select them and click create bridge.

Howewer in Ubuntu I couldn't do it, so I started looking around etc and setting manually then I installed bridge-utils, firestarter and netbridge still nothing

Then i used the command sudo ifconfig.

I was looking to see if I add any device with that unknown mac address for eth0 which I hadn't so I looked around more and there is an utility that changes the mac address. However as soon I change the mac address it resets itself right away. Is there a FIX to this so that it is set permanently because that is not recognized anywhere.

sudo ifconfig eth0 down

sudo macchanger -m XX:XX:XX:XX:XX:XX eth0

sudo ifconfig eth0 up

These are the commands I use. Is there a way to edit them into a script and put the script somewhere to make this solution permanent? I've seen somewhere that you could edit them in sysconfig but I used ctrl+h and didn't find sysconfig and those files to edit there.

Any help is appreciated

Thanks

EDIT: I forgot to say I am running Ubuntu version 11.10

share|improve this question
2  
Please consider adding more interpunction to your post, personally I find it quite hard to read. –  Cumulus007 Aug 20 '12 at 23:32
add comment

1 Answer 1

Assuming your PS3 is connected to your laptop using Ethernet, do:

  • Click on the network icon in the top right of your screen
  • Click "Edit connections..."
  • Click "Edit..." for the appropriate connection with your PS3
  • Click the tab "IPv4 settings"
  • Under "Method", select "Shared with other computers"
  • Click "Save..."

Note that you may need a crossover UTP cable to make this work. Also, I would advise to undo any changes you have made to the system in your pursuit of making this work.

share|improve this answer
    
Ok Cumulus007. Regarding the solution you posted it didn't work, I also already had tested it before because I have been changing values everywhere and everytime if it doesn't work I put them back on their normal state. What I need to know right now, is how to change eth0 mac address permanently , so that it never comes back to this eth0 mac address that corresponds to reality. I want to know a method better than macchanger. That might solve the problem thanks. –  likewyise Aug 21 '12 at 0:07
    
@likewyise Are you sure you are using a crossover UTP cable? Also did you actually test this just now, or are you assuming that it is one of the many "values" you have been changing? Because frankly the answer to your mac address question is simple (create a bash script, set a cron job) but I highly doubt it will help you do what you want to do in the least. –  adempewolff Aug 21 '12 at 1:47
    
@adampewolff: Isn't an ethernet cable the same as a crossover UTP cable? Also supossing I get a crossover UTP cable I have set the ethernet cable already, so that when I go back to windows xp, I get online in my ps3 via windows xp, doing that and getting a new cable if this cable is different from an ethernet cable, would make me have to change the cables everytime, unless this crossover utp cable you are talking about works in both systems. And regarding the bash script and set a cron job where can I find more info regarding that? Thanks –  likewyise Aug 21 '12 at 6:58
    
This solution simply must work. Have you activated the new connection from the network menu? Did you undo any of the scripts you have been fiddling around with, including the mac changer? –  Cumulus007 Aug 21 '12 at 10:00
    
Well I uninstalled every program I was able to get and erased everything, bought the crossover UTP cable and it still doesn't work, I also tried in both connections in wired and in wireless to put "Shared with other computers". Still it doesn't work. –  likewyise Aug 21 '12 at 19:09
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.