Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Asciiquarium is a perl script that requires Term::Animation. What are the appropriate hoops to jump through to get this cpan module into an ubuntu perl install?

apt-cache search animation |grep -i perl

doesn't seem to find anything like libterm-animation-perl to just apt-get blindly.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Perl modules that are not provided as debian package must be installed manually. One way of doing that: download the Term-Animation-XX.tar.gz source (XX is a version number), unpack it and do

cd Term-Animation-XX
perl Makefile.PL && make && make test
sudo make install

or you can use the automatic Perl module installer:

sudo cpan Term::Animation

During the first run, the installer will ask you a few questions that usually require just hitting Enter to choose the default option.

share|improve this answer
    
I also needed to apt-get install libcurses-perl before cpan succeeded –  Christian Nov 14 at 22:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.