Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted another question yesterday trying to determine if I had the proper video drivers installed and if my card was operating as it should. That was because I had some serious slow-downs in a game (through WINE). I know this machine is beyond capable of running the game (as it had in a windows virtual machine).

I fiddled with it yesterday and tried reinstalling some things (It's a RADEON HD 4800 series).

When I turned the computer on this morning and it booted to terminal after displaying the purple splash screen for an instant.

It allows me to login and then sits at my terminal name. As per a few other threads I tried the startx-command, while everything seems to be in order I did get this, which I assume is the problem:

(==)Using config file: "/etc/x11/xorg.conf"<br>
(==)Using system config directory "/usr/share/X11/xorg.conf.d"<br>
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

Segmentation Fault at address 0xc<br>
Caught signal 11 (Segmentation fault). Server aborting

I have no doubt it's related to my video driver problems, I am just not sure how to proceed from terminal as I'm pretty new to using terminal commands.

share|improve this question
    
Can you list what you installed yesterday? it seems that your xorg.conf has something wrong with it. Your best bet may be to delete your current config and try booting again. But first lets see what you installed. –  Jacob Tomlinson Aug 20 '12 at 14:21
    
I am embarrassed to say that I honestly couldn't tell you. It was a whirlwind day of trying to get things sorted, but I can say that I think most of what I was altering was uninstalling anything fglrx and reinstalling it. I know for a fact that my "Additional Drivers" menu shrunk from having both the "ATI/AMD Proprietary FGLRX graphics driver" and the "ATI/AMD Proprietary FGLRX graphics driver (Post-release updates)" to just having the one labeled Post-Release Updates. –  Madrigal Aug 20 '12 at 20:33
    
And would it be a matter of going into safe-mode and resetting the xorg.conf, as listed here: -[link]askubuntu.com/questions/131018/broken-xorg-conf-file –  Madrigal Aug 20 '12 at 20:36
    
I have also tried these commands, but it didn't change anything and the startx output remains the same. ==['code' sudo apt-get remove --purge xserver-xorg/ sudo apt-get install xserver-xorg/ sudo dpkg-reconfigure xserver-xorg]== –  Madrigal Aug 20 '12 at 21:34
add comment

closed as too localized by jokerdino, fossfreedom Nov 27 '12 at 12:39

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

I think I figured it out!

Tried the following in terminal:

sudo apt-get remove --purge fglrx fglrx-amdcccle
sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

Rebooted

Upon reboot it hit the splash screen and is now booted, but clearly on a reduced resolution, so I am without proper drivers (I assume), but I guess now all I need to do is install the proper ones.

EDIT:

Perhaps I spoke too soon.

I opened the terminal and ran:

sudo apt-get install fglrx fglrx-amdccle (I am quite sure that is what it was)

I rebooted after it seemed to install successfully and now the computer will boot to the "Ubuntu" splash screen and simply hang there with no progress, I can't even now get into terminal.

share|improve this answer
add comment

Simply going to reinstall 12.0.4.

Hadn't put enough on the box to make this a big inconvenience, better to start from scratch than try and work through right now. Need to use it.

Thanks all, please count it as resolved.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.