Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Ubuntu and I have some weird problem. I am trying to install a package called ckan. When I run the command sudo apt-get ckan, I have always the same answer : 'Unable to locate the package'. In fact, I notice I have the same problem with any package.

In the 'sources.list' file in the /etc/apt/ folder I have the following information. I tried to update, but the problem still remains the same

deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin...]
deb http://archive.ubuntu.com/ubuntu/ precise main restricted
deb http://archive.ubuntu.com/ubuntu/ precise-security main restricted
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted

Could anyone help?

share|improve this question

migrated from stackoverflow.com Aug 20 '12 at 14:07

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

This thread posted on the Ubuntu Forum sounds similar to your problem, this might help you "Unable to locate package" errors for all software

When in doubt during installation, always try running...

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

Btw, I don't think ckan is included among the official packages, have a look at this link for how to install ckan http://docs.ckan.org/en/latest/install-from-package.html

share|improve this answer
    
Thanks fo all these infos! –  user1611830 Aug 20 '12 at 13:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.