Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed ubuntu 12.04 (command line version) on an old machine (athlon 1,2 GHz, 1GB RAM, [SiS] 65x/M650/740 graphics). When I boot the screen turns black after the BIOS messages. Even grub doesn't appear.

The system reboots if I press Ctrl+Alt+Del. Ctrl+Alt+F2... doesn't bring my to any tty.

However I can access the machine via ssh (I installed it in expert mode and selected open-ssh-server during installation).

In spite of the black screen I tried to type in blind my username and password. Then I did touch test and I was able to verify via ssh that this created a file named test.

Any ideas how to fix this?


I insalled xinit and started blind startx but there was no X session, only a black screen. However I can verify via ssh that X was running.

Here is my /var/log/Xorg.0.log:
Here is my dmesg:
Here is my syslog:
Here is the output of lsmod:

share|improve this question
Initially I would recommend trying a reinstall as you haven't actually begun using the system and wouldn't lose anything. – Jacob Tomlinson Aug 20 '12 at 14:23
I guess doing the same install prodecure I would end up with the same problem. – student Aug 20 '12 at 14:24
Perhaps it has something to do with the SIS on board graphics, but I don't know what I could change.. – student Aug 20 '12 at 14:30
Provided your first install didn't have any problems ;) – Jacob Tomlinson Aug 20 '12 at 14:30
I have a laptop with SIS onboard and that runs ubuntu just fine. – Jacob Tomlinson Aug 20 '12 at 14:31
up vote 1 down vote accepted

I finally solved the problem completely by commenting out the line GRUB_TERMINAL=console in /etc/defaults/grub and doing sudo update-grub and sudo reboot.

share|improve this answer
That's great to hear, please mark your answer as the 'accepted answer' to help other people who have the same problem. – Jacob Tomlinson Aug 21 '12 at 9:28

Ctrl+alt+F7 is the means to switch to the standard GUI that I have seen. If that fails review what version you installed and ensure you wrote the desktop version, not the server (headless) version.

share|improve this answer
As stated in the title of the post in installed the command line version without GUI. – student Aug 20 '12 at 14:27
I just tried to install x via sudo aptitude install xinit and start it blind via startx to see if the problem has something to do with the framebuffer or something like that, but there is no X session, just a black screen (thoug X is running as I can verify via ssh) – student Aug 20 '12 at 14:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.