Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu in one of the laptops I own.

Since yesterday, and for no apparent reason, it is not able to connect anymore to my Wi-Fi router (I tried to forget the network and disabled security, still not connecting).

The confusing thing is that:

  • The laptop is able to connect to other Wi-Fis.
  • My other devices are able to connect to my router's Wi-Fi.

It is like the router and the laptop got mad with each other.

So I don't really know how to interpret this. Any idea?

share|improve this question
Does the router use WPA or WPA2? These two security methods are quite annoying. – hexafraction Aug 20 '12 at 12:33
WPA2, but I even disabled the security of the WIFI just to try, and amazingly it still refuses to connect, whereas the rest of the devices do...... and the laptop connects to other networks... i don't know what to think... I also restarted the router, I still didn't reset it. – edutesoy Aug 20 '12 at 13:08
Did you disable security on both the router and the laptop? – hexafraction Aug 20 '12 at 13:21
Well, i disabled the security on the router and then deleted the network on the laptop and try to connect to the new free WIFI as if it was an unknown one, and it was not able. My other laptop and phone were able to connect to the router... – edutesoy Aug 20 '12 at 14:21
What is the SSID? Ubuntu might not like some SSID's. – hexafraction Aug 20 '12 at 14:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.