Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My old GF 8600 went dead some weeks ago. While I waited for my new card, I used an old Trident PCI card to use the desktop. I could use windows but not Ubuntu, but I still removed several nvidia drivers using the command line: Getting an old Trident Video Accelerator 9440 to work

Two days ago I got my new card, a Radeon HD 5670. I reinstalled Windows, as it crippled itself because of the driver change (I use dual boot). The Windows install killed grub, so I reinstalled it using this: http://linuxpoison.blogspot.com/2010/10/how-to-restore-grub-2-after.html

After that, my three windows partitions could not be mounted during load time (guess that's because their mount folders are missing), and skipping the mount process lead me to a freezing black screen, so I commented the lines on fstab with nano. Then I restarted Ubuntu, but it keeps locking up at the black screen.

I guess Ubuntu is thinking I still have a GF, or it simply misses the nvidia display drivers. I googled around, but couldn't find any tip to solve my problem. I know ubuntu recognizes the card, as I can use Live CD perfectly.

Any help is welcome!


Edit:

My fstab: http://paste.ubuntu.com/545356/

My xorg.conf: http://paste.ubuntu.com/545357/

My xorg.0.log: http://paste.ubuntu.com/545358/

As I can see, I'm still hooked to nvidia. How can I wipe it out?

share|improve this question
1  
I couldn't help but read the first line of the last paragraph as "I guess Ubuntu is thinking I still have a Girl Friend". –  David Oneill Dec 16 '10 at 22:55
1  
I think it will help in troubleshooting if you edit the parameters GRUB passes to the booting kernel by removing "quiet" and "splash" and post here the messages you get during boot, particularly at the spot where it freezes. Also it might be helpful to post the contents of /etc/fstab so folks can see it. –  koanhead Dec 17 '10 at 2:06
    
@koanhead Thanks for the tip! I'll try it and post the results later today. And probably I'll keep 'quiet' out for good, seems helpful =) –  mdrg Dec 17 '10 at 10:23
    
@koanhead edited topic with forther info –  mdrg Dec 18 '10 at 19:24

1 Answer 1

up vote 2 down vote accepted

Sorry if I seem stupid: have you removed any possibly manually edited xorg.conf?

Still: does it seem like the kernel is activating framebuffer right from the start? I mean, when you boot, are you getting that fancy and pretty text mode at 160 cols x 60 rows (or something like that), or just the traditional 80x25?

share|improve this answer
    
First off, I'm pretty noob at Ubuntu. Guess the only thing I did about video was install proprietary nvidia drivers, compiz and X screen savers, nothing beyond that, much less manual files editing. And as I stated, I removed several nvidia packages... I may be missing some essential ones now. And the text mode seems 160x60. –  mdrg Dec 17 '10 at 10:18
1  
No problem, mdrg, so let's go. Based on what you said, I guess the answer is no, but please check if you have a file named xorg.conf at /etc/X11. If you do, please post its contents here, or better yet, search the file for 'Section "Device"' (and post that section contents).Nowadays, X11 configs are mostly auto-detected, but it could be that you happen to have this file with some settings –  Charles Roberto Canato Dec 17 '10 at 13:28
    
Another helpful file to try to diagnose what's going on would be /var/log/Xorg.0.log right after your last try. Both for posting your xorg.conf (or any part of it) and Xorg.0.log, I recommend you use paste.ubuntu.com and post its link here for us. –  Charles Roberto Canato Dec 17 '10 at 13:36
    
@Charlie Brown the file links are on the topic post. Thanks for your help! –  mdrg Dec 18 '10 at 19:25
1  
Thanks mdrg. As you said above, it seems your config files got stuck on nvidia config. As I trust the kernel and Xorg quite a lot :-), my first guess (and I think it has a very good chance of success) would be to get rid of that configuration. For that, just rename that config file (you'll need root access for that). If your config is default, open a Terminal and type "sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bkp". As you can tell, you'll just let X with no config file. In that mode, it'll try to probe whatever you got for it, and hopefully, it'll activate your ATI card. –  Charles Roberto Canato Dec 20 '10 at 4:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.