Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Let me start off by saying that I've been working on this for 6 hours, researching everywhere I can find online and not finding a solution.

I just installed Ubuntu 12.4 LTS and replaced Windows XP on my Dell Precision M4300. The installation went smooth, however now that it's installed I'm unable to get any type of internet connection; wired or wireless.

I've tried plugging directly into the modem, but the "Wired Icon" in the status bar constantly searches for a connection, disconnects, and instantly retries; non-stop. It never connects. I'm able to get a "connection" if I change the IPv4 connection settings to "Shared" rather than Auto, but it will not connect to the internet, it simply says that it's connected. I'm assuming that it has something to do with missing drivers (broadcom maybe?).

I've been all over the web but cannot find an answer. Please help get me on the right path. I'm fine replying to 15,000 comments to my question as long as I get one good answer out of it!


share|improve this question

OP Posted:

I found this page sitting open on my iPad. It solved all my problems!

Download the b43 zip file to a flash drive then drag and drop the file to your ubuntu desktop. Right-click it and select Extract Here. Open a terminal and do:

sudo mkdir /lib/firmware/b43
sudo cp Desktop/b43/*  /lib/firmware/b43
sudo rmmod -f b43
sudo rmmod -f ssb
sudo modprobe b43

A word of warning for downloading .zip files on the internet though, it might be more prudent to find the firmware from broadcom itself.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.