Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Only installed Ubuntu (and any linux) for the first time yesterday and am having, what I think is, a bit of trouble with my graphics card (Radeon 4800 Series)

The machine is capable of running Steam and the games I had running for it as a Windows XP PC (Specifically Total War) but now I find it struggles even to run Total War smoothly on the lowest possible graphics settings.

"Additional Drivers" says that I need the "ATI/AMD Proprietary FGLRX graphics driver (post-release updates)" but when I go to install them I get:

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log

Now, yesterday it had both that driver and another one without the post-release updates on it and something that I have tried in the last 24 hours has eliminated that "other" one leaving only the post-release driver option, but it hasn't fixed the problems I am having in-game.

I also have installed the Catalyst Controls which seems to give me the proper information about the card and lets me control the settings CCC allows you to control, but my problems persist.

My knowledge of Terminal is limited and I tried many things yesterday, I guess what I am wondering is first, if there is something I can do to check that the card is indeed up-to-date and running properly so I can determine if the problem lies elsewhere.

I apologize for my ignorance, I know this an often asked question but I've tried a lot and am just stone-walling.

Thanks!

share|improve this question
    
Can you post the output of the file /var/log/jockey.log ? Open a console by typing ALT+CTRL+T, then issue: sudo cat /var/log/jockey.log –  LnxSlck Aug 19 '12 at 23:56
    
The output seems to be really big would far exceed the character limit for posting it, is there a specific part I could post? –  Madrigal Aug 20 '12 at 1:03
    
So now the computer won't boot into GUI, just terminal. My hunch is that whatever I did to the drivers yesterday has buggered it up. I tried startx and among it all it gave me this: '(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found' –  Madrigal Aug 20 '12 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.