Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu Linux 12.04 version the latest right now.I want to mount an external HDD NTFS 1TB.I have followed many guides but still no success.The error I'm getting is this:

Failed to read last sector (1953523119): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdb1': Invalid argument
The device '/dev/sdb1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
Using Storage Device MAnager i get this error:Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdb1 on /media/Skliros_Diskos {external disk name} 

When I use sudo fdisk -l, this is the output:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000e0bc6

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   618854399   309426176   83  Linux
/dev/sda2       618856446   625141759     3142657    5  Extended
/dev/sda5       618856448   625141759     3142656   82  Linux swap / Solaris

Disk /dev/sdb: 1000.2 GB, 1000202043392 bytes
255 heads, 63 sectors/track, 121600 cylinders, total 1953519616 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002093a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048  1953525167   976761560    7  HPFS/NTFS/exFAT
share|improve this question
Is it a NTFS5 volume? –  Ignacio Vazquez-Abrams Aug 19 '12 at 17:32
Its file system is NTFS –  Slash Aug 19 '12 at 18:37
what is the output of 'fdisk -l'? and which command are you using to mount the HDD? –  Dan Aug 19 '12 at 20:07
I used the command Harshit ChaudHary told mount -t ntfs/dev/sdb1/media –  Slash Aug 19 '12 at 20:43
I edited the question now it has the output you wanted –  Slash Aug 19 '12 at 20:52

2 Answers 2

Try to see if there is an entry in the disk list with

sudo fdisk -l  

Then try mounting it with

sudo mount -t ntfs /dev/sdb1 /media

To find the correct /dev/sdb location for your external drive look at the result of sudo fdisk -l.

share|improve this answer
More detailed please i am an absolute beginner on this OS.But i will try these instructions –  Slash Aug 19 '12 at 18:33
I tried and i get the same error –  Slash Aug 19 '12 at 18:38
Any clues?????? –  Slash Aug 19 '12 at 18:38

Step 1: Create a folder

sudo mkdir /media/Skliros_Diskos

Step 2: Mount NTFS filesystem

sudo mount -t ntfs-3g /dev/sdb1 /media/Skliros_Diskos

Please note the spaces. As per your comment on the question, you did not add spaces in the command.

You should not mount it on the /media directory, since the system might use it thus might not allow you to umount the disk easily. Another reason is, when you plug-in another external drive, Ubuntu will automatically create a directory in the /media and mount the system on that directory, which could probably have some side effects, as the /media directory would be your external drive.

Once mounted, you can access it normally through Nautilus (The default Ubuntu GUI file browser). It should be listed in the list on the left side, if it isn't, press Ctrl+L and type /media/Skliros_Diskos.

Or you access it in the terminal with cd /media/Skliros_Diskos.

share|improve this answer
I used the command of step 2 and i get the same error.I copy/pasted it to be sure.I didn't made it on mounting it so i can't follow the next steps –  Slash Aug 20 '12 at 7:05
@Slash Are you sure your NTFS volume isn't corrupted? sudo ntfsck /dev/sdb1, this command will scan an NTFS volume for errors, are there any? –  Dan Aug 20 '12 at 7:29
i get the the same error with before –  Slash Aug 20 '12 at 7:59
When i use this command "sudo ntfsck /dev/sdb1 " I get the same error with this command "sudo mount -t ntfs-3g /dev/sdb1 /media/Skliros_Diskos" –  Slash Aug 20 '12 at 8:02
I tried to mount the volume of skliros_diskos from disk utility i get another error which is this:Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at tuxera.com/community/ntfs-3g-faq/#unprivileged –  Slash Aug 20 '12 at 8:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.