Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I bought a MacBook Pro 9,1 (Mid 2012, 15inch, NOT retina). Can anyone tell me how to install Ubuntu 12.04 on it? I already have Windows installed via BootCamp. Also, where to install drivers for Ubuntu and all? This link https://help.ubuntu.com/community/MacBookPro has nothing for 9,1 so please help me. If I have to remove BootCamp and reinstall Windows manually because BootCamp doesn't allow resizing of partitions, that's fine. Please tell me how to install Precise on MBP 9,1


share|improve this question
You might check askubuntu.com/questions/157514/… –  belacqua Aug 19 '12 at 17:46
What is "9,1" suppose to mean? When referring to MacBooks the year and screen size, or generation is usually mentioned. –  Yi Jiang Aug 20 '12 at 1:07
Added the year and screen size @YiJiang –  pratnala Aug 20 '12 at 7:42

6 Answers 6

My suggestion is to just install it on a flash drive and before it shows the apple boot logo, hold option key and select the flash drive. It performs surprisingly fast off a flash drive. I have a cousin that uses this method on his Mac.

share|improve this answer
But I want to do it on a partition. Could you tell how? –  pratnala Aug 19 '12 at 17:20

I have one of these and have still not got it all working properly. However I have managed to get Mint 13 (derived from 12.04) installed on it. The basic setup that you are asking about is described here. In order to get an Ubuntu live image to boot you need to pass some options to the kernel as described here in the section entitled 3rd attempt. I could only get it to boot from a DVD, it wouldn't work from a USB drive for me.

As I understand it, if you want to have Windows also then you can't use EFI boot, but the default install uses BIOS boot so that shouldn't require further config.

There is further discussion about this laptop on ubuntuforums.org (AU won't let me post any more links so you'll have to search) full support for it still seems to be a work in progress.

The key thing about booting from CD or HD in BIOS mode is to add "noapic" to the kernel boot parameters otherwise it will not boot. For EFI mode you need "noinitremap".

share|improve this answer
Can we interact on email? –  pratnala Aug 20 '12 at 7:50
It's probably better if you use the forum then everyone can benefit have a look at these threads. –  glennr Aug 20 '12 at 19:46
I only asked for email so that you could give the link (because AU isn't allowing you) –  pratnala Aug 21 '12 at 7:21
How to add noapic to kernel boot parameters? –  pratnala Sep 15 '12 at 6:42

I also have the MacBook Pro 9,1 (Mid 2012, 15inch, NOT retina). All these attempts did not work, mostly resulting in a freeze during the boot process (after selecting either to boot from CD/DVD or USB). I don't want any other distro but Ubuntu so i've decided to wait for 13.04. In the meantime i'm working with 12.04 on my Macbook Pro 8.1 and its perfect fit. I can't wait for April 25th (13.04 release date).

share|improve this answer
12.10 also has the same problems. Does 12.04 work perfectly on your 8.1? –  pratnala Mar 24 '13 at 10:40
12.04 is perfect on the Macbook Pro 8,1. :) Cheers. –  e-zy mann Mar 25 '13 at 18:53
Does it sleep and resume perfectly? –  pratnala Mar 26 '13 at 8:25
12.04 was made for Macbook Pro 8,1. That's all...the only bit i had to work on was hibernating and that was just editing a file. Enough said. –  e-zy mann Mar 26 '13 at 15:48
But 12.10 wasn't made for 9,1? :P –  pratnala Mar 26 '13 at 17:38
up vote 1 down vote accepted

What works for me (13.04 and above work well on a Mac):

  1. Install Ubuntu with the 64-bit ISO.
  2. For wireless drivers and NVIDIA drivers, go to Additional Drivers and install them.

Works like a charm!

share|improve this answer

So i just installed an almost "perfect" MacbookPro 9.1. A pretty long process but completely worth it! Here we go:

Install 12.10 -use the 64 bit version on the default download page -it has EFI boot support ie: ubuntu-12.10-desktop-amd64+mac.iso. -Download and install Refind on your macbook pro. -Hold down Option key during booting the macbook pro and insert the DVD/CD. Wait for it to be read and select "EFI Boot" NOT "Windows"

Upgrade To 13.04 (Its Pretty Stable For Me :) using for Java development) -Install and update your 12.10 completely. -Once 12.10 is installed and updated, upgrade to 13.04 using: sudo do-release-upgrade -d [it should now download the 13.04 packages and upgrade. Everything worked for me out of the box except my wireless]

Install Wireless: After a few searching and trials, i found this thread "http://ubuntuforums.org/showthread.php?t=1966236" ...that did it for me.

Suffice it to say that i'm writing this using the macbook now :) Enjoy.

share|improve this answer
I installed Ubuntu - the BIOS one not EFI install because I use Windows too and apparently you can't triple boot 3 EFI OSes :( –  pratnala Mar 26 '13 at 8:26
One more thing, were you able to install NVidia's drivers? I'm currently using X.org's drivers. –  pratnala Mar 26 '13 at 8:27
i didn't have to do all that with my approach. i'm comfortable working with just Mountain Lion and Ubuntu. It will take some work, i admit, so if u are up to it, then jump on!!! otherwise i will suggest waiting for the release from Canonical. Enjoy. –  e-zy mann Mar 26 '13 at 15:51
Well I use all 3 :P Thanks for the help anyway. Much appreciated! –  pratnala Mar 26 '13 at 17:38
Happy for you man, Wow!!!! Can you help? It can sleep and hibernate but it does not seem to resume after. I always have to restart(AND LOOSE MY WORK) after that. –  e-zy mann Apr 29 '13 at 11:52

I have a non retina macbook pro 9,1 as well. I followed the installation instructions for a mbp on the ubuntu website (with refit), but after the installation would complete, I'd reboot, and after passing the grub screen, get an unresponsive black screen.

The solution I found to get a good install is to remove all nvidia drivers after installation and before reboot, via sudo apt-get remove --purge nvidia-*. I don't know exactly why this worked for me, but it did.

I also changed the grub option "quiet splash" to "nomodeset", and ran update-grub after.

After these steps, I rebooted, and everything worked perfectly! Hope this helps.

share|improve this answer
on Ubuntu 13.04, NVIDIA drivers install perfectly. –  pratnala Jun 26 '13 at 7:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.