Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I suspend, I wake up. There is no network connectivity, there is no USB activity, there is no video output. The computer is turned on but nobody is home, just a black screen.

I have a 4 port KVM and a Geforce 9600 GSO.

  • I have tested connecting to this box via ssh, it times out

  • My keyboard doesn't respond when I try that session switch fix. I also tried a script that did the same thing essentially. Both failed

  • I have tested editing /etc/default/acpi-support (SAVE_VIDEO_PCI_STATE=true did not work)

  • I have tested the ACPI boot options.

(Result)

pci=noacpi doesn't work

acpi=off disables suspend so I don't even understand how that was a fix for someone.

I attempted to use a fix posted here https://wiki.ubuntu.com/X/Quirks#Force_Pipe_A_Quirk This broke x server so that it wouldn't run at all. I managed to disable it booting into recovery and editing the xorg.conf file with sudo nano. Booting normally it simply would freeze on the splash screen I couldn't get it to display what was going on so I had to restart.

I did find one fix for a laptop(which I don't have) that involved HDD power management stuff but I couldn't figure out how to do something like that for my desktop.

Couldn't find any help for this on irc, and my search results aren't pulling up anything new. Still haven't found what I'm looking for.

share|improve this question
    
recommend merge with askubuntu.com/questions/177628/… –  Mark Borgerding Aug 20 '12 at 14:06
    
Sorry I forgot one, I also tried that. –  Josh Aug 20 '12 at 15:10
    
Do you use disk encryption? –  con-f-use Aug 20 '12 at 15:26
    
No encryption. I do have my installation spread between two HDDs. I have a PATA and SATA drive (160/320 GB drives in that order). I have my SWAP at the front of the PATA and root at the back of it. Then on the SATA I have my /usr and /home then an additional mount specifically for files that I wanted set aside. However none of that should have any effect (in my opinion at least, but I am a newbie so I don't know) –  Josh Aug 20 '12 at 16:02
    
No solution, I will probably just give up on this. I will maybe get ahold of a SSD for my linux box and just hibernate... unless this gets fixed, must be a bug. –  Josh Aug 28 '12 at 6:48

2 Answers 2

Did you try this?

Force Pipe A Quirk This problem typically exhibits itself on Intel graphics hardware (most particularly i855) by locking up the machine when closing the lid. The fix for this issue is to quirk your card to force enabling Pipe A. If you suspect you're having this bug, try setting this option in your xorg.conf:

 Section "Device"
     ..
     Option "ForceEnablePipeA" "true" EndSection

Fore more reference visit the source of the above quote:

https://wiki.ubuntu.com/X/Quirks#Force_Pipe_A_Quirk

share|improve this answer
    
I have an nvidia graphics card and an AMD Athlon 64 x2 6000+ processor. Secondly, this is not a laptop with a lid, it is a desktop computer. So basically, no I haven't. Should I? –  Josh Aug 20 '12 at 16:13
    
well yes. first of all it says TIPICALLY on intel graphics, not only on intel vga, and second when you close the lid of the laptop you put it on suspend, thus, more commonly on a laptop. Since you suspend your DESKTOP it is exactly the same as you would close the lid, so yes, you shoud, then again, this is just MY option, everyone is free to do what ever they want. –  Rat2000 Aug 20 '12 at 22:26
    
Alright, it just struck me as more of a x server related issue than a suspend/resume one, rather triggered by the suspend/resume. I'll give it a try in the morning. I'll edit the details if it doesn't work. –  Josh Aug 20 '12 at 23:40
    
So this completely broke my boot cycle.... I don't think this fix was intended for me. –  Josh Aug 21 '12 at 19:19
    
did you manage to get it back? –  Rat2000 Aug 21 '12 at 19:33

looks like this answer is not much useful in your case.but its not bad to take a look anyway. I have to say that Im upset from this problem myself (Ubuntu 11.10,Nvidia GeForce 310M)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.