Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Summary:

  1. I keep getting the error: no such device grub rescue, after installing 12.04 (erasing an old 12.04 installation beforehand, but using the old /home mount, from a different HDD)

  2. I have two HDD 80 GB (used for /) and 250 GB (used for /home)

  3. I have tried Boot error > no such device: grub rescue and also using live cd then installing boot-repair, none of them solves the problem.

  4. Details from boot-repair: http://pastebin.ubuntu.com/1155292/

Question:

  1. I have tried a fresh install several time, and during these times, the two HDD mounted differently. I mean sometimes the 80 GB mounted as sda, sometimes as sdb. is this normal?

  2. Do you good guys at the Ask Ubuntu have any other way?

share|improve this question
add comment

1 Answer 1

  1. Yes this is normal. This random change happens with some computers.

  2. Try inverting the 2 hard disks in the BIOS boot order.

share|improve this answer
    
I think the problem is on the 80gigs HDD. I used the 250 gigs HDD instead and it works like a charm. thanx. –  simonsays Aug 22 '12 at 2:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.